WD DX4000 internal clock loose days when switched off (but powered)

Due to maintainance I have sometimes to reboot or switch off - switch on the two DX4000 units we bought (but everything remains powered). The DX4000 keeps the correct hour and minute but the day seems not updated and remains at the switch off date. This happens almost sistematically on both units. Is this another “feature” of the DX4000?

thank you




My date gets off on reboot sometimes.  Interesting.  Youi say it goes to when it was shut down.  May help in figuring it out


Yes. this happens either at reboot or just switching off (in this case most of the time more than one days are lost)

Did you try to solve the issue with the support or did you just accept it as a feature of the NAS?

never actually opened a support case.  Another MVP buddy of mine has the same issue and we have pinged folks who should be able to respond, but they never have

My only problem is when I forget it does this and joining a new computer fails

Well, just switched off for maintainance the server yesterday and today it is one day delayed. I did not find similar bugs even in the cheapest NAS we bought. I hope the support will manage to solve this issue.


Basically the answer I got from the WD support on this issue is that the problem is due to W2008 and it does not occur on versions installed using the English language (mine being Italian). From my experience the responsibility of faults for OEM o/s is on the hardware supplier, not on Microsoft, but maybe I am wrong. I was also told the unit was designed to remain always switched on, so basically it was my fault to swich off or reboot the unit from time to time.

As conclusion I had to find the solution myself which was the following:

Download DS Clock from http://www.dualitysoft.com/dsclock and install it on the DX4000 via remote control

In the options I set “adjust clock” every hour and checked “load program on start-up”

This way at least every time I reboot or switch off the DX4000 I have not to worry about the date delayed by one or more days.

My buddy and I see this issue and we are both English, so I don’t think they can blame it on that.  Joining it to a domain is also supposed to sync the clock but I don’t think it actually synced the date for some reason

Thanks for the update and give us a ping acouple months down the road and let us know if it is still doing what you expect.

FWIW I just tried the clock program and it would not fix my date :frowning:

That is pretty strange, it worked almost first time on both my units. Attached please find my configuration