WD Doesn't connect anymore

I bought a WD my Cloud device 2 years ago and it worked for a couple months and then no longer could connect it. I’ve tried upgrading the firmware but it didn’t help. Currently when I scan the network it doesn’t show the device as being connected even though it’s plugged in and has a blue steady light.

Any advice?

Have you tried connecting to the My Cloud via it’s IP address? One can usually find the My Cloud’s IP Address on the local network router’s administration page (under the DHCP server section).

One may also be able to find the My Cloud on the local network by installing and using the WD Access software. That software can be downloaded from the WD Support website: http://support.wdc.com/downloads.aspx

If the front light, LED, is blue, what are the rear LED’s doing. Are they on?

Hi Thank you for the help. I’ve tried using the dashboard url http://wdmycloud/ and it can’t find the device. What IP Address should I be using?

The front LED is now blinking orange. I don’t see any leds on the back.

Thank you.

I just redownloaded the wd setup and it doesn’t it find it on the network.

I think I’m going to reset the device and see if that helps.

Is the front LED orange or red? Is the My Cloud connected to a router?

I reset the device and now when the wd cloud program on windows 10 if finds the device. I can browse files through the wd cloud program but I can’t map it as a drive or browse it through windows.

Front Led is orange and steady. 2 rear leds around the ethernet connection are green, top one blinking, bottom one solid.

Now I’m accessing the device through

It shows up now.

After the web page access finished “Setting Up” I can access it through Windows Explorer.

To recap:

Quick Reset of device and then accessing it through have got it back up and running.

Thank everyone.

Does your MyCloud have the option for ‘Local Master Browser’ under network settings? If so, turn it on