Very slow transfer speed (1.8MB/s) when transfer large number of files

Hello WD community,

I recently bought and installed WD myCloud EX2 and start backing up files (small files ), but millions of them.  

The total data transfer is about 687GB (~6 millions files) over Cat6 cable (which I could get about 50% of total 1Gb Bandwidth when transfering a large file) .  I find that the transfer speed reported by Task Manager is at  0.8MB/s only.

The system I have Dell T7600  16GB RAM, Gigabit Network card, Intel® 82574L Gigabit Network Connection, which has the following configuration

  1.  Flow Control:  Rx & Tx Enabled

  2.  Jumbo Packet: Disabled

  3.  Link Speed & Duplex: 1.0 Gbps Full Duplex

  4.  Priority & VLAN:  Both enabled

  5.   Wake on Magic Packet: Enabled

  6.  Wake on Pattern: Enabled.

Anyone has this type of problem before?  Any insight on how to fix this is really appreciated ?

Thank so much in adv!!

Best regards,

JR

How exactly are you transfering your files? drag and drop using Windows Explorer? if so have you already mapped your drive properly in your computer? also you might want to check my suggestions  HERE eventhough I wrote that for the regular My Cloud it should be the same for any network connected device.

1 Like

Thank Eli,

I did a quick checked on services per your suggestion… they are all enabled.  And Yes!  I did the drive mapping and did the drag&drop files into the mapped folder.

One thing though, I am using switch,  http://www.tp-link.com/en/products/details/?model=TL-SG108#spec, instead of router.  Will this be a problem ? (i.e. I can’t do the forward setting you recommended in your blog).

Dear, I see exactly the same behavior with my setup : 

I’ve read a lot of forums, but still have an amazing slow performance. (max 3MB/sec).

 - Hardware laptop (HP Envy windows 8.1)
 - All windows services as mentioned above are set Automatic and running as described.
       1. DHCP Client
       2. NET TCP Port Sharing Service
       3. SSDP Discovery
       4. UPnP Device Host
 - Correct cables used
 - All servers in mycloudex4 disabled
     . no media serving
     . no itunes serving
     . plain setup
 - connected NAS directly to D-link wireless router (10/100)
 - mapped network drive (Z:) fom NAS public folders, and using drag and drop to copy
 - mapped external drive (Y:) (mybook), which is shown through the NAS
 Two ways of copying :
     1. External hard drive (mybook) directly connected to wdmycloudex4 through USB.
         result : max speed i’ve seen is 3MB/sec (drag & drop from Z:\xxx to Y:\xxxx)
     2. copy from laptop (windows 8.1) to NAS
          result : max speed i’ve seen is 1MB/sec (drag & drop from C:\xxx to Z:\xxxx)

Note : transfer is also slow with limited amount of files.

Padman wrote:

Dear, I see exactly the same behavior with my setup : 

 

I’ve read a lot of forums, but still have an amazing slow performance. (max 3MB/sec).

 - Hardware laptop (HP Envy windows 8.1)
 - All windows services as mentioned above are set Automatic and running as described.
       1. DHCP Client
       2. NET TCP Port Sharing Service
       3. SSDP Discovery
       4. UPnP Device Host
 - Correct cables used
 - All servers in mycloudex4 disabled
     . no media serving
     . no itunes serving
     . plain setup
 - connected NAS directly to D-link wireless router (10/100)
 - mapped network drive (Z:) fom NAS public folders, and using drag and drop to copy
 - mapped external drive (Y:) (mybook), which is shown through the NAS
 Two ways of copying :
     1. External hard drive (mybook) directly connected to wdmycloudex4 through USB.
         result : max speed i’ve seen is 3MB/sec (drag & drop from Z:\xxx to Y:\xxxx)
     2. copy from laptop (windows 8.1) to NAS
          result : max speed i’ve seen is 1MB/sec (drag & drop from C:\xxx to Z:\xxxx)

Note : transfer is also slow with limited amount of files.
 

We are currently investigating this issue. 

Some additional info : 

  • when not using the wireless but connected through cat 5e network cables, the maximum I hit is 7Mb/s.

Max I have seen is 11 MB/s, regardless if transfering via WiFi or LAN (Mac Mini)

Dear,

I called WD support (Belgium) and a case number was opened.

I’d like to mention that the person giving support was extremely helpful and we digged the problem down through elimination :

  • First attached the NAS to my fastest (windows 8.1) laptop directly (provided network cable)

  As Expected the read and write speed were as written by the specifications. (which is normal) 75Mb/s and 40/Mb/s

  • Secondly, used my network cable (CAT5e, 5meter) and hooked the NAS on the network (LAN, not wireless)

  Speed went down, but transferring files where still in the area of 27Mb/s (on average)

  • Afterwards did the same test through wireless which brings it down signifinately.

  Most probably access point related.

I will try to use a new router as the one I’m using now and will update the results soon.

In any case, for all people having troubles, log a support call at WD (see their website).  I can not stress enough how helpful they were.

Thanks,

Pascal Droogmans

Padman wrote:

Dear,

 

I called WD support (Belgium) and a case number was opened.

I’d like to mention that the person giving support was extremely helpful and we digged the problem down through elimination :

 

  • First attached the NAS to my fastest (windows 8.1) laptop directly (provided network cable)

  As Expected the read and write speed were as written by the specifications. (which is normal) 75Mb/s and 40/Mb/s

 

  • Secondly, used my network cable (CAT5e, 5meter) and hooked the NAS on the network (LAN, not wireless)

  Speed went down, but transferring files where still in the area of 27Mb/s (on average)

 

  • Afterwards did the same test through wireless which brings it down signifinately.

  Most probably access point related.

 

I will try to use a new router as the one I’m using now and will update the results soon.

 

In any case, for all people having troubles, log a support call at WD (see their website).  I can not stress enough how helpful they were.

 

Thanks,

 

Pascal Droogmans

 

Hi Padman,

Glad we were able to help.