WD My Cloud 2TB - slow transfer

Hello,

I bought my WD My Cloud 2TB yesterday. I plugged it to my router - Sagemcom Fast 3764. And i have troubles with the transfer speed - max. 5,5MB/s. It’s terrible…

Is it possible to speed it up? If yes - how?

Thank you in advance,

best regards,

Martin

what are the lights on the back by the Ethernet cable doing?

what types of files? approximate sizes and number?

what FW version?

One light is steady-green, the other one is blinking-green (maybe the cause is that I’m playing now a movie from my cloud on my TV).

I’m copying .mkv files, about 2GB each.

FW v04.01.00-408.

That looks good on the mycloud end.

it appears that somewhare it is running 100Mbps Ethernet which makes the 5.5MBps still a little slow but not unreasonable, I would expect more like 7-9MBps but many things can impact that

what are you copying to/from?

Are you sure the other device is setup for 1Gbps Ethernet?

are both devices plugged directly into the same router? or are there other switches/hubs/etc involved?

I’m copying from my laptop (windows 7) through WiFi. It’s a Lenovo G510 with Qualcomm Atheros AR8172 card.

My laptop and my cloud are connected to the same router.

Could the cause for this slow transfer be a WiFi connection?

7-9MBps is the most what i can expect? It’s not to much. I hoped for a faster transfer when i bought My cloud.

I think i shouldn’t try to copy a bigger movie, like 15GB…

I had the same problem before. Slow transfers. Make sure your router has a gigabit ethernet port. I was getting lousy 5kb on transfers. Now, with a router with a gigabit ethernet port, I get 40kb - 50kb speeds. Make sure the computer and router has gigabit ethernet ports.

Here is a diagram
http://wdc.custhelp.com/app/answers/detail/a_id/5736/~/when-transferring-large-files-to-or-from-a-personal-cloud-drive,-performance

it is probably the wifi that is limiting it. on a hard wired gigabit Ethernet expect 70-90MBps, the 7-9MBps second was guesing that somthing in the path was only 100Mbps Ethernet

On wifi there are man factors the impact speed, what modes do your laptop & router support? How far away are they from each other. Electrical interference from almost anything

does the labtop have a gigabit Ethernet port, if so try that for a test

I’ve had the same problem with mine, whether it’s transfering from my dektop to the mycloud, or through the USB port.  I finally gave up because I have almost two TBs of movies I want to move, and it looks like it could take 3 or 4 days.  The crazy thing is the USB port is transfering files at about USB 1 speeds.  I transfered the same file from my external drive to the cloud as well as from my desktop to a seperate USB drive, and it took exactly two and a half times longer to transfer into the mycloud through the USB port.  And the same file transfered from my desktop to another desktop on our home network take 50% longer to transfer to the mycloud.  Why the heck is the thing soooo slow?  Tech support were no help, in fact he told me it’s faster to transfer files from a seperate PC than to use the USB port.  Sadly the dude didn’t even know the mycloud has a USB 3.0 port.  Houston. I think we have a problem. 

How are you transfering between the mycloud and the USB attached drive? If you are using file explorer/finder all the data comes down to the PC then back up to the mycloud

download the WD Mycloud app for this the copy should stay in the cloud. I don’t really like this app for LAN use but it is good for this porpuse

you can also do copies in Linux but I don’t recomend it unless you are very comfortable with Linux

Well that’s the most helpful thing anyone has offered. I’ve been using explorer in windows. I use the WD software. Thanks!

If we could be there to see the issues most would be resolved quickly

since we can’t be there somtimes it takes a lot of back and forth and trying different things to get a better picture

for most issues someone here has already worked through it

Thank you for all the answers.

I checked my routers specification, and see that the ethernet ports are “10/100/1000BT” (does it mean, that it’s a gigabit router?), but my laptop has only a “Atheros AR8172/8176/8178 PCI-E Fast Ethernet Controller (10/100MBit)”, and propably this is limiting the speed.

When I connect the my cloud directly to the laptop, the speed grows up to ~11MB/s, it’s still not good enough but two times better than through wifi…

I think it’s impossible to change the ethernet in my laptop, so is there any other possibility to speed it up?

Otherwise connecting my laptop via an ethernet cable is not the most comfortable thing, because my router is standing in the hall. I’m ca. 3-4m from it in another room, with a wall between.

So the 70-90MB/s I can get only through a cable ethernet connection? And through wifi?

Does your laptop supports usb3? If yes the followings should help:

  1. Usb3 to gigabit ethernet nic adapter (preferred, almost as fast as 1G built-in nic if you have a good cpu).

  2. Usb3 to wifi ac nic adapter (expensive and if your router supports ac mode).

Only usb2? A usb2 to gigabit ethernet adapter is your last hope though you’ll never achieve true 1gbps. Theoretically usb2 spec is 480mbps but 80% efficiency is twice higher than 100mbps nic.

Yes, it supports a usb 3.0 port. So i’ll look for this adapte, and hope it will get better.

Sadly, there’s no possibility to connect the my cloud directly to laptop through USB like a external hard drive… it would be very helpful.

martinmel wrote:

Yes, it supports a usb 3.0 port. So i’ll look for this adapte, and hope it will get better.

Note if you are getting usb3 wifi ac, your router must support AC mode else you’ll fall back to N mode (your current wifi speed?) or lower.

 

Sadly, there’s no possibility to connect the my cloud directly to laptop through USB like a external hard drive… it would be very helpful.

I don’t think there’s any NAS which can do this but the least, wdmycloud -> ethernet-to-usb-adapter -> laptop :dizzy_face: