WD MyCloud EX2 1Gb/s problem

I’m having a problem with my WD MyCloud EX2 transfers. Few days ago I’ve decided to upgrade my network a bit, so I could get 1Gb/s transfers across my network. I bought new switches etc, upgraded cables (cat6). Everything appears to be fine. Windows reports to be working on 1Gb/s connection, all “leds” are green (orange -> 100Mb/s, green -> 1Gb/s). But whenever I download something from my WD… all I get is 12-13 MB/s total, which is “perfect” for 100Mbit… but not 1 Gbit

To make everything clear:

-> My PC is set to 1,00 Gbps Full Duplex and says everything is fine,

-> My PC Network Card Led is “green”, which confirms statement above (or at least it should)

-> MY WD is set to work in “1000” speed mode (tried “Automatic” too)

-> MY WD Network Card Led is “green”, which confirms that it should work in 1Gb/s

-> There is just a 0.5m Cat6 cable between WD and PC (I’ve connected them directly to each other, but still the same effect). I’ve also tried few other cables both Cat6 and Cat5e - no difference.)

-> WD Firmware was upated to “1.05.36”

-> My PC Lan driver was updated (it’s an Intel Card on Asus Rampage V Extreme) too…

… tried with a different PC too -> the same…

Welcome to the Community. 

Have you been able to confirm if other devices are also behaving this way on your network? Is your router ALSO Gigabit capable?

My PC and Laptop (MacBook Pro) are connected via the same router and I can transfer files with full-speeds (close to 100MB/s). Whenever the Mac tries to upload something from NAS… it’s also stuck with 12-13 MB/s

So:
PC -> NAS (12 MB/s)
MAC -> NAS (12 MB/s)
PC -> MAC (100+MB/s)

So… I’m pretty sure that it’s all my WD’s fault for low transfers. 

P.S. Since I can get into MyCloud EX2 OS via SSH… is it possible to check whenever it’s truly running 1GB/s? I’ve tried couple of typical Linux/UNIX commands (ethtool etc.), but the OS appears to be pretty “clean”.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

Support by Country
http://support.wdc.com/country/index.asp