Very Frustrated - WD My Cloud 3TB is not recognized on wifi

Hi All

I recently bought a 3 TB My Cloud and I have been having problems discovering it through myriad means right out of the box. My first unit was replaced under warranty after facing a similar problem and eventually not powering on to the stable (blue light) state. The second unit has been connected properly to a Dlink 2750U router, and all the indications such as stable blue light and the LAN cable lights are normal. The device again was not discovered on wifi and was set up using the wired LAN connection using a laptop running Win 7 64 bit and WD MY cloud setup for windows. I spent more than 3 hours with my ISP’s technician and also more than an hour on two separate calls with WD support without the problem having been solved. Here’s a list of fixes that were attempted:

  1. Using the My Cloud setup and WD discovery software

  2. Using another laptop (this time Win 8)

  3. Converting to a static IP in the dashboard (through a wired LAN)

  4. DHCP reservation using MAC address in the router

  5. Combination of 3 and 4 above

  6. Assigning an IP outside the range of reserved IPs in the router

  7. Router firmware/reset

  8. Disabling all firewall and parental controls in router and computer

  9. Reinstalling ethernet/wi fi drivers in laptop’s control panel

  10. Couple of other solutions advising disabling and enabling options in control panel --> network and sharing after driver reinstallation

I do not think this is a laptop issue as I have tested it out with another laptop and there is a similar issue of not being discovered on wifi. All my other devices such as laptops, WD 1TB Elements hard disk on the USB port of the router, a chromecast dongle and assorted android devices are discovered without a hitch if I were to cast aspersions on the router itself (Dlink 2750U). The only thing that can be done is to test the device in a different wifi network which I am going to do today after work. It would be incredibly bad luck if the unit under warranty replacement is also having similar problems. I would appreciate any thoughts and solutions as I have spent the better part of 3 days trying to use the 3TB device the way it is meant to be.

Thanks in advance,

Harsha

Since the My Cloud has no idea whether your client is Wired (which works) or WiFi (which doesn’t) then it would be very difficult to say the issue is with the My Cloud since it makes no difference to it.

You might check your Windows Network Profiles, since your WiFi network interface will have a different profile (and have different policies) than your Wired network interface.

I understand. This is a unit under warranty replacement and is highly unlikely to be defective a second time around. Is there a way to ensure the same connection policies are enforced for both LAN and wireless? Or is there a way to check for differences in the policies?

Thanks

Harsha

The problem was solved by some Dell NAS technical experts after a lot of headscratching at my end. The problem was the “enable multiap isolation” option in the router. Once this was disabled, wifi access was not a problem.

Thanks

Harsha

1 Like

Thank you for sharing also the solution, not only the problem!

Same here. I bought a WD MyCloud 2 TB, but my Mac does not recognize it in disk uitilties.

WD SmartWare also does not do what WD promises.

I can’t even format my WD MCloud!

Gleen

smartware is only for windows, mac used time machine

see my response in your other post for more details

GlennMaitree wrote:

my Mac does not recognize it in disk uitilties.

Nor should it.   Disk Utilities isn’t for NASes – only Direct Attached (DAS) storage.