My cloud setup cannot detect my cloud on network

i have a 4tb my cloud and a mac. i have Att u-verse internet. my cloud used to work fine on time warner cable before. I did some research and found out the router of att does not support upnp. I then went and bought a net gear switch and connected my cloud to switch and then switch to the router. I have a blue steady light in the my cloud. when I run my cloud setup for mac. it says No Wd My cloud found on network. I really need help. the router that I have is a Pace 5268AC.

Good morning

I have a similar problem with my 3TB MyCloud. Initially it was available but then it it became inaccessible.

Will follow the replies or will appreciate advice as to how the problem can be fixed.


welcome to the non connectivity club, WD don’t care to help with this problem. I haven’t been able to access my 3tb my cloud since october 3rd. I have tried several methods other than de/unbricking the drive or data recovering I don’t think anyone on here knows how to solve this conundrum. However if you do manage to get a fix please please please do share! :+1:

Ps. I’m a firm believer that the problem was firmware update has screwed the comms board connected to the hard disc.

**Update, I phoned WD. After going through several steps the operator from WD informed me that the drive is done. He informed me that it is ok for me to take the drive to be data recovered and then WD will replace the drive completely once I have my data recovered.

I had the same Mac connectivity problem, tried all sorts including advice to install the Beta Apple 10.11.2 so I signed up for that and it seemed to work for a few hours. then it stopped letting me do anything at all in the device. I decided to do a full factory restore, having waited 13 hours I searched the forums to see others had waited 40 hours or more and still had problems. I tried clicking the quick restore button but nothing happened the cloud kept spinning. I decided that after a year of frustrations it was time to put a hammer through the device and buy a different make. I unplugged it to stop the restore process then did a quick check, Dashboard took me to set up, the device now has a full 2 Tb of free space and it also now shows in my Finder sidebar. I created one new folder and exported 1 photo successfully, now about to export 37,962 Photos - hopefully doing what I shouldn’t have done - namely unplugging the device mid process has made it work - counterintuitive but looking good so far.