No WD My Cloud Found

Hope someone can help as currently you canot email in a support request and as it’s the weekend I can’t phone either so am stuck!

I have a brand new WD My Cloud. It’s connected to the same switch as my laptop. The switch is Powerlined to the internet router and I have internet access.

The LED is blue.

I can see the WD My Cloud in my Network on my laptop (Windows Vista can even see the default shares) and have downloaded the WD Discovery software that can also see it and even give me it’s serial number.

BUT the setup software cannot find it - I have tried rescanning several times but it just says NO WD My Cloud Found. 

Consequently I am unable to continue the setup. This seems a tad ridiciolous consdering the above…

Aha discovered I can configure from the Discovery program. So tried that only to get the following error message when I click Finish:

  • Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance. (200500)


1st there is no setup program needed just go to http://myclould/ui or it may be wdmyclould

This brings you to the dashboard.

Is your PC getting dhcp through the powerline and switch? Dhcp service is required to the myclould for initial setup. I suggest a static IP for ongoing use.

What are the leds on the back of the myclould doing?

Same problem here: cannot connect to it. My mac can find it, but the install program says that it cannot check my Firmware and my browser gives me a 403 forbidden. But i see the device in my finder. Anyone a sollution?

Have you tried connecting directly to the router?

What do you mean by that? I connected the WD to my Apple Airport Basestation and trying to connect with it via my Macbook.