"No My Cloud Devices Found"

When I go to mycloud.com/setup, it says “no my cloud devices found.” I have tried putting in the MAC address, but no luck. The device is on, lights solid blue, and it is definitely connected to the same network as my laptop.

Hi there,

Try to disable cloud access then reboot the device, once the device is rebooted, try to enable cloud access to see if this helps.

Hello,

Check your local PC firewall, malware, antivirus settings and allow traffic from mycloud.com.
Also check your router settings and allow traffic from mycloud.com

Regards,
Samuel Brown

Just bought this today and connected it to a Comcast Infinity router Technicolor Model TC8305C. My Cloud’s blue light is on. Tried everything suggested here and WD still can’t find My Cloud. How can I “disable cloud access” when the My Cloud is not seen by anything since it is no connected (physically) to my desktop computer? Plus I’ve read several ways in WD literature of downloading software. All of the screenshots in each instruction are different, as though WD keeps updating its control panel. Which is the most current?

If you go to your router’s control panel, and go to ‘advanced settings|home network’, can you see your mycloud listed as a device connected to your router?

If not, you need to resolve that.

If you can, note the IP address it has been given, then open a web browser, and enter

<IP address>/UI

In the address bar, where <IP address> is the IP address you noted. This should give you access to the Dashboard.

Note that you do not need to download any WD software to setup and use your MyCloud locally.

[edited to sort out the mess this stupid forum makes of < and > characters]

Thanks. I email-chatted with Comcast Infinity and they gave the address to the router’s control panel, which is not accessible otherwise. (I bookmarked it for future use.)
I see “WDMyCloud” listed under Connected Devices. But if that’s true, why couldn’t WD locate the router last night from your installation website?

Is your router’s ‘hidden address’ 192.168.1.254/landing.lp by any chance? If so, that’s the address of the Technicolor UI…

But if that’s true, why couldn’t WD locate the router last night from your installation website?

Because WD’s software is a bit flakey…? That’s why i said you don’t need any of it… I don’t work for WD. It’s not my software. Almost no-one on this forum works for WD; we’re customers, just like you.

So, now you can see the MyCloud is connected to your router, can you access the Dashboard using the IP address?

I’ve located the My Cloud’s IP address by clicking on its name, put it in the browser as you advised, and I now see the “Choose Your language” control panel that the My Cloud literature wants me to see. Thanks for all your help. (I was about to regret I’d bought this!)

Im having the same problem. I can see it in the router, I can paste the ipaddress/UI in the browser and connect to the dashboard. But on files.mycloud.com/setup it cant find my device and it cant locate it from the MAC address either. Ive rebooted, I’ve switched clould access on and off but no luck. Is there a wd live chat help? has anyone figured this out?

I got the same issues…

i gave up…

I worked trying to get their software to work and had the same problems, it would not find my device on my network, I finally found this software (it might be an older version, I don’t know) but it works and I have access to my drive over the internet and can save and drag and drop files and they go to my drive…it works…
http://setup.wd2go.com/?mod=faqs&device=mc&faq=accessComp

Hello All,

What routers are being used?

MyCloud.com/setup uses forward and reverse DNS to discovery.wdc.com
This means the PC, MyCloud and the Router must all forward and reverse resolve mycloud.com and wd2go.com domains. If DNS doesn’t resolve, MyCloud.com/setup will report “No My Cloud Devices Found”.

How to check?

Open a command prompt and type:

nslookup wd2go.com
nslookup mycloud.com

If DNS is resolving, then something else is going on such as local DNS binding or other.

This is what I got when I did the nslookup’s:

C:\Users\xacgl>nslookup wd2go.com
Server: cdns02.comcast.net
Address: [[DELETED - PRIVACY]]

Non-authoritative answer:
Name: wd2go.com
Addresses: [[DELETED - PRIVACY]]
[[DELETED - PRIVACY]]
[[DELETED - PRIVACY]]

C:\Users\xacgl>nslookup mycloud.com
Server: cdns02.comcast.net
Address: [[DELETED - PRIVACY]]

Non-authoritative answer:
Name: mycloud.com
Address: [[DELETED - PRIVACY]]

I have Comcast internet and phone so they sent me a modem/router, its an Arris (brand name) MG1682G (model), it has a 4 port gigabit hub and dual band wifi built into it.