Help! Cannot detect mycloud in setup

Hey all,

I tried to install mycloud using http://wd.com/setup/wdmycloud but during the install I got the message it couldn’t find the mycloud, while the mycloud is giving a solid blue light on the front.

The WD discovery program can find the WDMyCloud, but when I select the mycloud and try to configure it WD Discovery says I do not have permission.

I use a Netgear FS205 switch. I tried to turn it off for 3 minutes and back on again, but this also didnt help.

I also tried to connect to http://myclould/ui , but all my webbrowsers (Chrome, Firefox and IE) say it cannot find it.

Does someone knows what I can try to make this work? I would be very gratefull!

Thank you!

I have never used that “setup” site, it is not needed

the URL to use the dashboard is http://wdmycloud/UI if this dosn’t work go into your router configuration and see what IP address the mycloud has, then us http://MyCloudIPaddress/UI to access it.

I suggest setting a static IP outside of the DHCP pool once you have access

none of the WD programs are required for local access

Thank you for your quick reply! 

Maybe this is part of the problem. I do not really have a router because I live in a student home run by a big organisation. I have a little box in the wall were my internet comes from. I connected this box to my Netgear FS205 network switch, and the switch is connected to the Mycloud. The switch does not really have a configuration.

does you PC have a static IP assigned by the “orginization”? or is it using DHCP?

if the PC is using DHCP you should by ok but you won’t be able to set a static IP and can’t access the router to determin IP. this will work but could be a little less stable

also be aware that everyone on the network can access and public shares, and if you enable media shareing they can view your content.

have you tried the http://wdmycloud/UI URL? you could have an issue with someone else having a mycloud with the same name.

you could try connecing the mycloud directly to the PC. reboot the mycloud. change the name to somthing unique, shut it down move back to the switch and try again. no all computer seem to suport this but I believe most do.

 Thank you again for your quick reply!!

 About the static IP / DHCP :  I do not know how I can use this for the sollution? SHould I call my provider to ask what type I have?

I connected the mycloud directly to my computer and the connection succeded. I changed the name and connected it to the switch. Unfortunately I still have the same problem and cannot connect to the http://wdmycloud/UI URL.

Ah I found the Network option

http://support.wdc.com/images/kb/11384_2.png

It is now set on DHCP. Should I try the static IP one? I am only not sure what IP adress I should fill in there…

to check your PC open a command prompt then enter ipconfig/all  you will see a line that says DHCP enabled and either yes of no. I suspect yes. If it is no then you will need to see if you can get another address assigned for the mycloud

DHCP is probably the only option for the mycloud as you don’y want to set it to static unless you can get one assigned by the facility network people.

in you post you still showed http://wdmycould/ui but now it should be http://NewMyCloudName/UI

The command prompt says I have DHCP.

If I try to go to the new adres, http://RicoMyCloud/UI ,it still does not work. When I connect the mycloud directly to my computer the adress does work.

The weird thing of this all is that the WD discovery ‘finds’ the mycloud when it is connected to the switch…

Also, when I try to connnect via the WD discovery programm it says:

"Forbidden

You don’t have permission to access /UI on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

"

maybe this helps finding the problem.

bumb

when connected to the switch what are the 2 LEDs by the Ethernet cable doing?

what user/password are you using when you get the UI permission issue? If this is a new device the user is admin and no password

The LED on the switch is mainly solid and blinking sometimes, just as the other connections (that do work) do.

The 2 LEDs behind the mycloud: 1 is solid orange and 1 is blinking unregulary green.

About the permission issue. I just type the IP of the page: http://82.149.98.165/UI and then I get the permission issue. I do not need to put a password or user anywhere. 

 none of the WD programs are required for local access

Yes. This is one of my main criticisms of the User Manual; it encourages the novice user to download a raft of programs, most of which are not needed, or are only needed for remote access once you’ve got the thing set up and have figured out how to make it visible to local devices, and have data on it.

The redundancy of control and access methods is not explained, leaving a novice user somewhat unsure when to use which tool…

Tover

Are you sure you have the corect IP address? Generally you would have a non-routable address provided by your router. this sounds more like an IP address that your provider may have assigned to your router

what is the mycloud connected to? What is the computer conneted to?

in a command prompt on the PC run ipconfig/all to see how it is configured. typicaly you wil have a subnet mask of 255.255.255.0 which mean your PC needs an IP address of 82.149.98.x where x is not 165, 0 or 255 (based on the IP address you supplied)

edit: I forgot the back story here. The IP still sounds odd. How did you determine that IP address? can you post the result of ipconfig/all from your PC? if you don’t want to post it in public send me a message with it

Yes I am sure. I unplugged the mycloud for a while and when I tried to go to the IP adres I got this: 

http://i.imgur.com/0qUlGQ8.png

So atleast it is the right one. Only now it is stuck at ‘attempting to authenticate’.

I checked in run --> cmd – > config/all and my computer has a different IP…

you got that message while the mycloud was disconnected?

what is the IP and subnet mask on the PC?

 Are you sure you have the corect IP address?

Larry, remember that Tover’s situation is a little unusual, in that he doesn’t have an ADSL or fibre router, but plugs a simple switch into some Ethernet infrastructure at his student facility.  Whilst you might expect this to still have a local IP addressing, it’s possible that they have assigned them ‘real IP’ addresses, connected directly to the internet.

In which case, if I were him, I’d be asking about firewalls, as he appears to be connected directly to the internet at the moment, so is rather vulnerable to all sorts of attacks that a router’s firewall protects you from (somewhat…).

My networking is a bit rusty, but I suspect his switch may only be a layer 2 MAC switch, and not an layer 3 IP router.  Which might cause some confusion if trying to do device ID using IPs…?  I can’t remember how devices on a MAC switch are distinguished from each other…

This is what RIPE has to say about that IP address:

https://apps.db.ripe.net/search/query.html?searchtext=82.149.98.165&search%3AdoSearch=Search#resultsAnchor

Don’t know if that sounds familiar to Tover…

Tover, sind sie in Oberwart?

I forgot for awhile, basically I am trying to see if they are actually on the same subnet at this point, if so he should be connecting directly through the switch, if not I suspect he is stuck as the facility is blocking him

I think the problem is in the router provided by my students organisation. When I connected the mycloud to the switch and my computer to the switch it worked and I could connect to the mycloud (without the internet cable to the switch). When I connected the internet cable to the switch it suddenly didnt work.

I can’t change the internet provided by the organisation, so I decided to bring the product back to the store. I want to thank you for all the help :slight_smile: