Cannot see the WD mycloud on Network

This is the item I bought


I looked over the forum for my problem but could not find anything similar.

Our network is very simple - cable modem - wireless router with 4 Ethernet ports - and 3 computers. Probably like many of your homes/businesses. Out of the box the instructions are simple enough. Go to a page, click on download, install, hookup to Ethernet port on router, scan for devices.

Did all of that - 20 times. No device found…

Call tech support. From there it got dicey.

“First can we turn off your firewall?”
“Run arp -a on a command prompt”
“Run ipconfig”
“Change from DHCP to static”
“Type in this address”
“Scan for devices”
“Hmmm… could you call your internet provider and see if they know what the problem is?”


90 minutes of this **bleep** went on and in the end I don’t have a storage device, I don’t have LAN connectivity, and I am NOT a happy camper with Western Digital.

Ok, maybe some dumb questions…

You say you’ve plugged it into your router – Have you plugged in the power?  (Yes, people have neglected this step before),

After it’s been plugged in for 5-10 minutes, what’s the status of the LED in the front?

What’s the status of the LEDs on the back (there are two) and also on the Router port you plugged into?

Have you logged into your router to see what IP address it’s assigning the Cloud?

And to further expound on that previous post.

My “network” has worked fine for the past 12 years. This CS guy had my go into the config files of http://wdmycloud and make changes there. As I recall we set it to static and used Googles server or something like that as well as subnet and IP addresses he gave me.

When it was all over, I still did not have a storage device. But, here is the kicker. All 3 computers (2 desk and 1 laptop) were now kicked off the network with LAN. The laptop has built in wifi so I disconnected the LAN cable and wa-la! Back on the internet.

Hence, his suggestion to me to call Suddenlink and see if they can fix it now…:angry:

Nope bud, trust me - I never consider any questions “dumb”.

Yes to power

Solid blue on the front

One green solid and the other flashing intermittently on the back

Never got that far for the last question.

The only thing we were able to establish is that it does show up in my network when I connect it directly to my laptop and that is it.

Also the port was 3 or 4. Sorry, forgot to mention that

Have you checked to make sure they are all in the same workgroup? See image below for the My Cloud.

Check this link out and see if the information helps. Be sure to check the
My Cloud │How it Works tab.

Posted by,
cat0w (USA)

Ok, I’m scratching my head now – you say you are able to log into the Cloud’s Web UI on your network, but your subject line says you see it on your network.

If you’re able to get to the Web UI (which means it IS visible on the network), exactly what is not working?

Sorry, may not have been clear enough.

Let’s just say for the sake of brevity - it never worked.

I went through 90 minutes with level 1 last night and just wrapped up a level 2 (I presume) today that went another 2 hours.

At this point we are at a crossroads where he cannot log on with his desktop but he can with his mobile Android. He took some screenshots and is working towards a solution.

3.5 hours so far working with people that are MILES above me in knowledge for this kind of thing.

But, I have calmed down because there is something to be said about excellent tech support and even though we are not “fixed” yet, I appreciate the effort the most.

Keep you posted.

when you say the network has been fine for 12 years, does this mean you have the same router etc as 12 years ago?

do you know if the router is providing DHCP service? can you log into your router ti see if it shows the mycloud connected. If so try pinging the IP address from each computer

No, it is on it’s 3rd iteration. (B - G - N) Pretty much plug and play swap outs. But, this configuration that blew up last night had been in play for the past 2 years with zero issues.

Today, the level 2 removed the static IP and set the cloud back to DHCP as is the rest of my network. We also did a hard reset on the router, modem, and cloud and that was able to get the device visible. 

Again, we are still encountering remote logon issues, but at least it is heading in the right direction.

(And yes, we pinged it many times)