Upgrade stuck on "Upgrading ... (-1%)"

Hi,

I have a “WDMyCloudDL4100”. I’ve followed the steps found on both links

https://support-en.wd.com/app/products/product-detail/p/128#WD_downloads
https://support-en.wd.com/app/answers/detail/a_id/29813/

I’ve made sure to update my firmware first to 2.41.116
After reboot, I then clicked on the alert to upgrade to “My Cloud OS 5”
The screen shows the FW downloading.
However, when it gets to the “Upgrading” status, it hangs on “(-1%)”

I then downloaded the OS 5 FW
Version: Firmware Release 5.15.106 (7/13/2021)

and manually attempted to apply.

Webpage shows it “downloading” from my desktop.
When it attempts to Update, it fails with “Upload firmware failed. Try again.”

please assist.

@BruceBanner We’re unable to duplicate your issue.
Have you tried to manually upgrade using a lower version of firmware such as 5.11?

https://downloads.wdc.com/nas/WDMyCloudDL4100_5.11.112_prod.bin

1 Like

No I have not tried an earlier version. When I went to the download page for DL4100, only the latest FW is listed.

I will try the v5.11 you listed.

Upgrading to v5.11 worked!
Thank you so much.

After reboot, OS5 stepped me through the welcome screens and basic setup.

Thanks Again!

Are you planning to try the newer revisions of OS5 ?

I have just experienced exactly the same problem as Bruce. Same model same problem. The upgrade firmware version showing in my dashboard is only 5.14.105 but I get the -1% hang and Firmware Update Failed displayed on the DL4100.

Will the firmware upgrade automatically from 5.11 to the latest 5.14/5.15 after a manual update using your link?

I was able to upgrade to the 5.11
then after my NAS rebooted to the OS5 - it found the newer FW.
I was able to upgrade to the newer FW fine.

1 Like

I have the same issue running MAC OS latest and DL2100 sticks at install-1% thats it nothing else happens