Update 4.3.327 don't work with mac high sierra and mojave

Update 4.3.327 don’t work with mac OS high sierra and mojave. My cloud desktop send me a error Unable to communicate with the desktop daemon. Please try again later.

1 Like

Similar here. Both MCH Drives don’t show up in Finder anymore. Even not after restart.
Another fail update by WD.
Let’s see how many months we are going have to wait this time until we will be able to use our divices again.

1 Like

Been waiting ages for the Apple Silicon version for my new Mac and now this! :face_with_symbols_over_mouth:

Does anyone hade the previous version laying around for my older Mac? Been googling for hours and didn’t find it.

1 Like

Good afternoon
I have two Western Digital external disks.
One is a WD Cloud of 4 Tb and a WD Home of also 4Tb
As they do not appear in the Finder I am only being able to connect to them in my Mac through the explorer.
As I have already spent SEVERAL FULL DAYS trying to setup them, and with the update that was made yesterday, the situation is even worst and I am not finding any solution for this in the net.
This situation is not acceptable.
Can someone please suggest a different supplier for wireless external disks?
Thank you!

WD Discovery for macOS. (this may be an earlier version than the current 4.3.327, depends on when you actually downloaded it). Current size is 135 MB (142,298,174 bytes).

WD Discovery Full installer for Mac

https://download.wdc.com/wdapp/WD-Discovery-mac-full.dmg

There is a version from 3/27/21 size 134 MB (141,356,693 bytes) if anyone is interested.

Same here. MCH drive doesn’t show up in Finder but it does appear on WD Discovery after sign in. But when I click on my MCH in WD Discovery, nothing happens. It usually would open a new Finder window with my directories.

WD - please fix this ASAP!!

I have already tried this solution but with out no luck.
Don’t understand way, but I think, that login’s are having issues.
If you logged in and don’t update, your fine. If you are logged out and tray to login again, not even with an older version.

Hope WD solves this issue soon!

Everyone with a failed install may have to completely remove WD Discovery and reinstall as suggested by cme of WD.

Please ensure that the WDFinder Extension is enabled within your macOS:

If the issue persists, please follow the steps in the following articles:

How to Uninstall and Remove WD Discovery on Windows and macOS
https://support-en.wd.com/app/answers/detail/a_id/4158

WD Discovery Fails to Install on macOS
https://support-en.wd.com/app/answers/detail/a_id/28936

Please open a case with the support team, if the issue persists, so the issue can be further investigated.

https://support-en.wd.com/app/ask

No proposed solution works

I tried all that but nothing helps.
Finder Extension is and was already checked.

No success.

Made full uninstall
Cleaned any files left in hidden folders
Reboot
New installation
Logged in (Drive appears only on the WD discovery APP)
Verified that extension where active for finder (It was already)

But no success on having access to the Drive, or appearing on finder. :frowning:

2 Likes

Did not work :frowning:

1 Like

No luck :frowning:

1 Like

Please just make the previous version available again. Thats a quick fix we need now!

3 Likes

I’m on El Capitan OS X 10.11.6 and also affected.
I’m facing the exact same issue as described by everyone here as well, after updating WD Discovery to 4.3.327 today.

Tried a clean uninstallation and re-installation (have also gone through and performed all the troubleshooting steps mentioned above) to no luck.

I’d like to ask WD to put out the installer to the previous working version please. That’s a quick fix and workaround we need for now.

2 Likes

Manage to find an old version in a thread on this forum. I’m up and running again on High Sierra :+1:t3:

Can kindly share the link please?

Can you please share the link?
Thank you

Please note this version is from Oct 2019 by SBrown of WDStaff

4 Likes