Big Sur Support! FAIL! WD has FAILED the community!

Mac OS version 11 Big Sur will be released soon.

You, Western Digital, have not done your part to be ready for the release of this upgrade!

You have FAILED as a vendor. You have FAILED in keeping your software up to date! The beta releases have been happening for month now! Certainly you have a team the is working on this!

Overall, I, and the rest of the community are disappointed with your lack of promptness is this matter.

Your MyCloud is a door stop with ZERO usefulness! Thanks a lot!

1 Like

Hi,

You may refer to the following KBAs:

This is not working. But why? Very interesting question.

Works, thanks.

nonesense… this is not working… what kind of product you are selling ?.. guys … please suggest me another product to move the data also …

this doesn’t work…
i will sponsor a Crow bar to the WD CEO … its better you go out for looting … that has more decency…

I have installed WD Discovery for macOS 11 Big Sur but myCloud drive is still not showing in the Finder.

2 Likes

me either!!! how do we fix this? :thinking: :thinking:

You have to install a release version of macOS 11 Big Sur, it does not work on the beta versions!

I am running the released version. :thinking:


when i open the installation which is mentioned above, i get this and regardless i upgrade or don’t upgrade …nothing happens even today …
get this stupid thing fixed first asap …

Buy a Synology. Seemed to fix all my problems.

I just upgraded to macOS 11.0.1 Big Sur, and upgraded WD Discovery to version 4.2.288. I found that I could not log in : eternally spinning beachball. I then uninstalled all WD software (Discovery as well as Drive Utilities) via the supplied uninstaller. I discovered that there were some undeleted preference files, and deleted them too. Then I re-installed WD Discovery 4.2.288, and this time, all went well.

Please fix this ASAP, everybody in my office upgraded to Big Sur and nobody can connect to My Home Cloud. So disappointed.

WD Discovery support for Big Sur can be found using the following article:

Install WD Discovery for macOS 11 Big Sur

Please use the install package within the article.

Would you mind posting a screenshot of your app working in your macOS big sur… this is the fourth time I am trying to install this . Please stop sending bogus posts to create the nuance of you have already delivered the patch

you are not alone… you are conned

Same problems here. I don’t even see my MyBook driver anymore.

for all of you who still could not get around with the big sur support issue, please follow the steps below:

  1. remove the previous version of wd discovery and desktop by following the steps from the link below:
    https://support-en.wd.com/app/answers/detail/a_id/4158
    you may want to follow the steps on step 7 from the above link to remove everything .

  2. install the bigsur.dmg from the following link :
    https://downloads.wdc.com/mycloudhome/WD-Discovery-macOS11-Big-Sur.dmg
    launch the app and then login, this should work for all…
    let me know if this works for you .

shame on WD support for not telling us this earlier.
shame on WD App developers for not developing the installer to remove the previous versions during
the installation of the new version of App.

1 Like

I have installed the updated WD Discovery for Big Sur and am able to log in to the app, however when I click on my drive to access the folders and files, nothing happens. I have tried uninstalling and reinstalling and restarting the computer each time, but with no joy. I now wish I’d waited a few more months to update my OS to Big Sur :frowning: