Mac - Big Sur 11.0.1 - I can see all folders in web based My Cloud, but only TimeMachineBackup in Finder

On my iMac and two MBPs, I can see all of my folders in My Cloud Home when I use the web, but when I click on My Cloud in Finder, all I can see is TimeMachineBackup.

I don’t know why this has happened, as I was using My Cloud folders in Finder, perfectly well, two days ago. (Just realised it’s probably something to do with Big Sur update.)

Is there a way in which I can see both folders and TimeMachineBackup in Finder?

That’s a problem with the new version of Mac Os. WD said that is fully functional but it is not true.

There are a lot of users facing the same issue than you. It is necessary a new update from WD or it won’t run again

Please see the specific WD Discovery Big Sur update with the following article:


cme
WDStaff

10h

Please see the specific WD Discovery Big Sur update with the following article:

support-en.wd.com

Install WD Discovery for macOS 11 Big Sur

why you are lying… ??your stupid app doesn’t support Big Sur…acknowledge that you are working on it… hire some IT staff to develop the App … spend some money… don’t just disappoint the community by selling incompetent stuff…

Hello , this does not work , the mycloudhome duo (mounted in JOBD) files don’t appear anymore on the finder , if there is a workaround just tell us , (not the web browser thing ), i need it to appear in the filing system , for my workflow , thank you in advance .

Hi again Comunnity!!!

Here you have the SOLUTION!!!

This is the link to download the latest version, fully FUNCTIONALLY AGAIN!!!

https://downloads.wdc.com/wdapp/Install_WD_Discovery_for_Mac.dmg

hello
did you manage to make it work? , the finder on mac (tried it on two macs )does not see myclouhome hdd. if yours work tell us how you have done it , please ?

  1. Download the file linked in my previous message.
  2. Open it
  3. Install it
  4. Open the software, and it will say that you need to accept the security privacy in your mac’s settings.
  5. Restart
  6. Run!!!

excuse me for my imprecision , i have done that already , before my last question .Do you see the cloud homeduo on your " Finder " ?
i managed to make it work on my mac book pro but not my imac , could someone help please ?

Don’t worry!! I will do the necessary to help you.

I think you do wrong on step number 4… Look at this step and follow it strictly:

  1. Download the file linked just here https://downloads.wdc.com/wdapp/Install_WD_Discovery_for_Mac.dmg

  2. Open it

  3. Install it. (When finished, the system will say you that “you need to give administrator permission to the app” or something similar. And you’ll only see two items (1. Accept, and 2. Open system preferences) ---- If you press the first one you will fail. You need to push the second one, called as “Open system preferences”. Then, you need to open de lock of the screen that will be open, and introduce your administrator password. When done, you need to press the button to give permission, or to allow the app, or something expressed in a similar way.

  4. Restart

  5. Run!!!

thank you for your time of course i have done that and even retried after your answer ,to redo it by uninstalling the software and residu ,like the site of wd has suggested it , i even went to the container files in library( wd , and wanted to look at it , it is empty , contrary to the mac bro ( i am trying all this on an imac ) on which the volume file is populated . the only difference between the 2 the imac has 3 sessions and i am on admin one connected via ethernet , and the mac pro with wifi , and of course the two of them are running big sur ,

I have tried these steps many times. The problem is that after I installed the app (in step 3), there was no “security permission” request popping up. I also tried uninstalled the app, deleted all the related folders/files (following the instruction of WD) and reinstalled the app, with no luck either.

I am using MacBook Air (with M1 chip). Not sure whether this may impact.

Thanks.

I have tried these steps many times. The problem is that after I installed the app (in step 3), there was no “security permission” request popping up. I also tried uninstalled the app, deleted all the related folders/files (following the instruction of WD) and reinstalled the app, with no luck either.

I am using MacBook Air (with M1 chip). Not sure whether this may impact.

Thanks.

ARM processors are not supported.