macOS Big Sur’s imminent release

The next OS which was announced in June 2020 is nearing its release. For the past few OS versions, there have been big compatibility issues with WD Discovery which took many weeks and months to resolve.

It can only be assumed that WD is better prepared for the next OS release which has been made beta available since June.

This the question: is WD Discovery compatible with Big Sur?


Literally just joined to say the same thing :sweat_smile:
As it currently stands, for me at least, the answer is No.
I’ve installed the Big Sur Beta on my iMac - loving the new OS and timemachine to the My Cloud Home is still possible, but access to the private share side is not. The WD Discovery app installs, and runs, and I can enter my login details for my account, but when I click the drive under the Storage tab, nothing happens (whereas it used to mount the drive as a volume in the Mac).
I’ve tried explaining this to WD Support, but I’ve just been told to install the WD Discovery app each time, which is obviously what I already have installed and uninstalled and reinstalled etc.
Hopefully they’ll get it sorted soon… I’d hate for my drive to just become obsolete when it’s not even a year old yet :sweat_smile:

1 Like

Big Sur is being released to the general public in a few weeks. Can we get an answer as to when WD Discovery for Mac will be working on the new macOS? For the past 3-4 years, WD has faced this issue without much concern to the fact that it does not have compatibility on day one.


I can confirm that Big Sur broke WD Discovery. My Cloud Home is not showing up in finder

1 Like

Done that still no drive in the Finder :pensive:


1000% agree, WD help, is there a solution to this…?? :pray:

I hit this exact issue on Friday and it is not resolved. I was using my drive for both data and Time Machine and neither is working / accessible.

I have wasted an enormous amount of time trying to get assistance from support. All I get is variations on a theme of ‘uninstall / re-install / re-boot’ and it makes no difference.

Another one affected with the same issue.

I guess It would be solved in the next update. The problem is when would it be?

Dear WD, as a tech company, this is unacceptable. Everybody in my office upgraded to Big Sur and cannot access to My Cloud Home.

I am waiting for the problem to be resolved

1 Like

WD Discovery support for Big Sur can be found using the following article:

Install WD Discovery for macOS 11 Big Sur

It doesn’t run. I have updated it but no signal yet

1 Like

Downloaded the latest version of WD Discovery (Released on 18/11), still not able to install it, kept stuck at 50%. It ■■■■■

1 Like

The community continues without any solution.


The following article provides the latest WD Discovery build. (updated 11/18/2020)

Hi again!

Here you have the link to download the latest version! This is fully FUNCTIONALLY!!!

It’s still not working for me. I’ve checked my permissions, restarted the MacBook. Still no visibility in Finder. Is there some other setting or trick to make this work?

I have the same issue. I downloaded everything, gave permission to the drive and it is still not showing.

1 Like

Don’t worry team!! I will do the necessary to help you all.

I think you do wrong on step number 4… Look at this step and follow it again strictly:

  1. Download the file linked just here
  2. Open it
  3. Install it. (When finished, the system will say you that “you need to give administrator permission to the app” or something similar. And you’ll only see two items (1. Accept, and 2. Open system preferences) ---- If you press the first one you will fail. You need to push the second one, called as “Open system preferences”. Then, you need to open de lock of the screen that will be open, and introduce your administrator password. When done, you need to press the button to give permission, or to allow the app, or something expressed in a similar way.
  4. Restart
  5. Run!!!