Big Sur Support! FAIL! WD has FAILED the community!

please follow the steps to completely remove older version and try installing again

https://downloads.wdc.com/mycloudhome/WD-Discovery-macOS11-Big-Sur.dmg

This link is working!
Because if you download from this link https://downloads.wdc.com/wdapp/Install_WD_Discovery_for_Mac.dmg
it download not the Version: 4.2.288 but previous Version

Hi, I just installed the updated WD Discovery (no need to uninstall anything as this is the first time I’m trying to connect my Mac to this WD drive). Still, when clicking on the drive icon, nothing happens. I must mention its protected with a pass. Please, do you have any suggestions on how to proceed further on? Big thanks!

I just re-did it with the different steps and made sure that absolutely everything was removed. And restarted the computer multiple times after making the updates. As before, I get to be logged in my drive and able to see what storage capacity remains, but when I click on the drive to see my folders, nothing happens. Nor can I see the WD Drive mounted on my desktop.

1 Like

I don’t even see how much is available…I only see the icon and that’s it.

Bought a MyCloud Home 8TB three months ago, and am unable to access the folders in the MacOS Finder. In Finder it also only shows the Backup folder and no other folders.
In the IOS app I can see how much space is remaining on the drive, and that’s it. When I select the MyCloud Home link it doesn’t do anything. I have renamed my MyCloud Home in the IOS app however in Finder it possesses another name, e.g. MyCloud-H04EGC, and it only shows the backup folder.
With only three months use of this device I am considering returning it. I also own two older 4TB MyCloud hard drives and they both still work in the Finder window. It therefore seems that Western Digital is regressing in their support.

It still doesn’t work for me even though it sounds like it should. I only see the Time Machine backup folder but I don’t see anything else. I can add things through the web interface and on my Windows 10 machine but not with the production version of macOS Big Sur which is what my MacBook Air M1 shipped with (only days old).

After spending about 2 hours or more with 2 tech support colleagues on consecutive days and despite their conscientious and thorough wfforts they could not get my mycloud to stay connected with Big Sur. What else could it be but a problem with MyCloud/WD programming for the interface between mycloud and Big SUr? My MacBook Air which runs the earlier MacOS has absolutley no problem with MyCoud via my home and its connections. Very sad and frustrating since no other apps have that issue.

I have tried all these remedies of deleting previous versions and installing new versions for Big Sur but I still cannot get any MyCloud applications loaded.
We need a simple complete download that fixes all the stray files that need deleting and then installs something that runs properly, not some collection of fixes involving the use of Terminal and checking ports are free. Most of us are not familiar with all the intricacies of programming and need a plug and play solution please WD.
My MacBook and iPad both kicked our MyCloud off after the latest OS upgrade. The MacBook gets stuck at 50% extracting files for the Big Sur installation pack WD are recommending.