macOS Mojave (10.14): private space not available in the Finder?


#1

Hi,
I just updated my MacBook to macOS Mojave.
My My Cloud Home’s private space is not mounting.
WD Discovery was updated to 3.0.384 (the release notes are yet to be published) and thought it would ensure full compatibility with macOS Mojave.
So far, it does not seem to be compatible with the latest version of macOS, the private space is not being mounted.
In addition, WD Discovery inelegantly shows up in the new section (recently used app) in the Dock.

Hopefully, an update will be released soon.

Best,

AF


#2



#3

Hi,
Thanks (also it’s annoying that My Clod Home is not supporting Mojave day one mostly because it uses non standard network shares technologies).
However, the article point to Discovery 3.0.377 whereas I’m now running 3.0.384. So is it still accurate?

Best

AF


#4

Anyone know if theres going to be an update soon. I am also experiencing the same issue where I cannot browse my files through finder after updating to macOS Mojave.


#5

Sigh, this is extremely disappointing. It is not as if WD is a small company that would have trouble keeping up with upcoming changes in an OS.

the Mojave Developer program has had early access to the OS for MONTHS, and it’s been in Beta for quite a while… What were you guys doing that you let this slip by.

Geez


#6

The link above says

The next release of WD Discovery is scheduled to be available between the end of October to mid-November time frame. Please check https://support.wdc.com/downloads.aspx?lang=en#WD_softwaremac for software updates and macOS 10.14 Mojave support release. We apologize for any inconvenience this may cause.

Good luck everybody!


#7

I’m having the same problem :frowning:


#8

So, is there any way the fine folks at WD can expedite this update? It is completely unacceptable that developer betas for Mojave have been out since June and they didn’t see fit to plan ahead for this. This can be pretty crippling for users who rely on this service every day and now download files they need to work on, and save everything to their internal hard drives before transferring them to the cloud drive.

Come on WD! You’re a pretty large company to have not figured all of this out already


#9

IMPORTANT UPDATE:
A macOS 10.14 (Mojave) supported version of WD Discovery is scheduled to be available within the next few days. We apologize for any inconvenience this may caused.


#10

Great news.

What’s new with 3.0.384, which has been pushed a few days ago, it is not yet detailed in the release notes.

If it is the update you are referring to, it seems not ensuring compatibility with macOS Mojave.

Best,

AF


#11

I’m not amused by what’s happening.

It can not be that a network hard disk is not reachable within the network.

It is temporarily not even an alpha or beta released, so you can access the data locally again.
A terminal command as a workaround for the add would also be enough or you change the software so that it is reachable as normal as the userspace and you can select nfs or smb yourself and you have no more problems! Should one now wait with each update so that one can access his data again locally?


#12

Wow this is a poor experience. Made this forum account for this 1 and only reason. I purchased my home cloud 4tb the other day. Worked perfectly, until i updated to Mojave. Now, no finder integration (cant access or easily manage my files other than web interface) and get internal server error in discovery app, despite it showing me logged in. PLEASE PLEASE GET A FIX ROLED OUT FOR THIS SO MY DRIVE SHOWS IN FINDER ! WD just went from an 8/10 company to a 1/10 company. I have work to do and have to use the web interface, thanks a bunch :frowning:


#13

Here’s how the update works if you have WD Discovery 3.0.777 or 3.0.384 for macOS (10.11, 10.12, 10.13 and 10.14)


Mac beta user Mojave - WD Discovery
#14

Yeah, but how do we get the 0.93 version??

EDIT, Its just updated to latest version and its working perfectly. Thanks WD


#15

Hi,

My version of WD Discovery v.3.0.384 it’s ok but MY Cloud v.1.5.0.79 how to update my cloud ?

Thanks


#16

Just quit (log out) of the WD on the top menu then log back in and you should have a red badge notification to update. Worked for me.


#17

Hi,

should the update start automatically? My version of WD Discovery is 3.0.384, but the My Cloud Version is still at 1.5.0.79

When I try to log out and log in again, the “internal server error” occurs again, and no update hint is shown?


#18

Rather than logging out, try quitting the app, (bottom right)


#19

Nothing new…


#20

@DaneEder the update is automatic. If you logout and login using 1.5.079, you’ll get the “Internal Server Error” so just wait for the update to apply.