Wd discovery failed to install & wd discovery update failed mac

I’m using wd discovery 2.2.408 mac and tried update to 3.0.250 but got the message ‘wd discovery update failed’.

Therefore I uninstall and download latest wd discovery 3.0.250 but got the message wd discovery failed to install.

I tried to install again using 2.2.408 then it successfully installed.

I can’t update and install only 3.0.250.

I uninstalled any anti-virus software already and here is my device information.

mac OS High Sierra 10.13.4 MacBook Pro 13-inch 2017

I have the same issue as subindesign.

macOS High Sierra 10.13.4 MacBook Pro (15-inch, 2017) ==> update failed
macOS High Sierra 10.13.4 iMac (Retina 5K, 27-inch, Late 2015) ==> update failed
macOS High Sierra 10.13.3 MacBook Pro (15-inch, 2011) ==> update success

Same Exact issue on macOS High Sierra 10.13.5 MacBook Pro

I don’t see any one giving any solutions on this forum. All concerns are left open ended. WD techies are least bothered it seems.

1 Like

Hey, any news on this? I have the My Cloud Personal and could not use in Mac in home.

This is frustrating.

I have the same and reiterate install problems with wd discovery on my macbook pro 2018 (macBookPro 2018 - Mac OSxHighSierra 10.13.6) . It does not install and continuously install errors. There is no note on how to solve this problem, and this is definitely bad.