Cannot install WD discovery on my Mac OS

Hi!

I got a new WD mycloud home and I tried to install WD discovery 3.0.260 from wd webpage but I cannot install it on my Macbook pro Retina (15inch , mid 2014), version 10.13.4.

It starts unpacking and it comes to some 60% of installing and then just automatically shuts down the application and thats it.

I tried multiple times, also restarting my computer, everything, but it cant be installed.

Then I try my old macbook pro 13inch late 2011 with 10.11.3 macos and it is installed without problem the same app downloaded from wd page (wd discovery 3.0.260)

Is there any bug or someone had the sam eproblem or someone from WD support could help me with this problem?

I googled all the links but I cannot find the solution.

Similiar problem is maybe here but there was no answer or solution:

Does anyone has some older version of WD discovery? I cant find them on wd page.

Thank you very much!

1 Like

@bsumrada Please open a support case with use and attached the WD Discovery Debug Logs


Hi!

We have already made support case. And I also checked if I ahve any hidden files for WD discovery logs but there is no files because WD discovery is not even installed. Also during starting the installation before it is unsuccesful I checked if there is any logs but no luck.

Any other help?

Thanks!

1 Like

This may be your issue or you may have to uninstall and remove the old version of WD Discovery to install the 3.0 version.


Hi,

I (still) have the same WD installer (v3) issue as described by bsumrada! the installer starts to download but at some 50% on the progresbar it just quits and that it … no message …it even dismounts the installer disk icon …
target system: iMac 27inch , OSX 10.13.4

Been in contact with WD Support sice april 27 on this (10 messages) but I feel they give up now … (saying sorry and given me discount on next purchase … )
We looked for hidden file , old WD software or parts of it, monitoring software tools etc , but nothing helps …

I was able to run the WD Discovery installer on a other Mac here though … running the OSX before High Sierra … updated that Mac to 10.13.4 and WD Discovey is running oke still …

The installer seems to be picky some how on it OS environment … and anything WD might have placed on your system before … !

But I still need a solution/fix for this to work with teh NAS as planned at purchase moment.

PS I have all my disk hardware from WD, running fine …

Thanks!! anyone !!??

I have not find any solutions to my problem yet. It looks like wd support do not know how to solve the problem :frowning:

Can we share/find the wd discovery 2.2.408 version?

I have your own and annoying problem and although I have read all the possible news about it I have not yet solved. Have you solved?

No. I would like to find the link to download the previous version 2.x
It’s a shame. Have this device for 2 months and it is useless.

This issue was first posted in April. I can’t believe it’s still not solved. I’m thinking of returning it and buying the competitor’s product. Unbelievable.