Cannot uninstall or reinstall WD Discovery for Mac

Pleeeeease can someone help! I’m very computer literate, but the WD My Cloud is really testing my patience. I can’t install WD Discovery on both of my Macs and use the My Cloud as a bridge as I thought I would be able to, transfers over wifi take forever and the Mac Time Machine backup - which is what I bought it for routinely has little success (after the initial week! that it took to back up).

Right now all I want to do is update the WD Discovery software (as prompted by the apps own software). For the past 2 days, I have been trying to update the software only for it to constantly fail at the point of installation, to then tell me it needs updating. I thought I would try and find the latest dmg file online to install but it seems to not exist online. So I thought I would roll-back to a previous version. I overwrote with effectively the same version that I already had only to be given the message “this version of WD Discovery is already installed on your computer”. So I followed instructions to delete these files:

/Applications/WD Discovery, remove it if it still exists
/Users/user name/.wdc, remove it if it still exists
/Library/LaunchAgents, remove everything which starts with com.wdc

And with various restarts, uninstalls, reinstalls etc. nothing has worked. I simply get the same message “this version of WD Discovery is already installed on your computer”. so right now the drive is useless as I can’t even access it on my desktop. Please can someone shed some light before this thing goes out the window!

Many thanks

Did you follow this procedure?
In the mean time, you can still access content from Mycloud.com
https://support.wdc.com/knowledgebase/answer.aspx?ID=20731&s=#macos

Hi

Thanks for your reply, I followed these instructions here:

So the uninstaller is now gone, but didn’t actually appear to do anything when I did run it. It definitely didn’t do anything from point 3 onwards in the link you sent. And now I have used a third party uninstaller to remove all traces and when I install the software again, It still says that version is already present on the machine?

Hello… I don’t know if you are still having this issue but I eventually figured out the problem and managed to get WD discovery to re-install in my MacBook Pro. I had the exact same issues as you and it took a few hours to realise the problem.
Firstly yes follow the online instruction and delete all WD files from hidden library on Mac. What they don’t tell you is you then have to also delete them from the system library folder!!!
In your Finder window under devices click on the name of your computer. Then click on your Hard Drive, mine is called Macintosh HD. Now you will see a few folders, one called users, one called library and system. It’s inside this library folder that there are still WD files which you need to delete.
Just go into library, spotlight search WD and delete all related files .plist etc. Do the same with the system folder.
Then reboot the computer and re-install, worked for me after hours of pulling my hair out…

Chris

1 Like

That’s excellent thanks! You are the man!

No probs!

Hello Chriscameraop,

I really really hoped that your solution would work.
Unfortunately it didn’t do the trick…

If I install WD Discovery again, it doesn’t install fully.
And I still can’t use the WD Discovery app as before.

Do you have a other way to solving this problem?
Anyone? Please help

Ralf

If you are having installation issues on macOS 10.15 Catalina, please download and install the
full version of WD Discovery 3.5.138 located at https://downloads.wdc.com/wdapp/WD-Discovery-darwin-prod-x64-3_5_138_full.dmg

Thank you!
I have the app on my desktop like before.

Thanks SBrown

SBrown,

The app is back on my desktop and I’m logged in.
But I can’t get in to my Hard Drive.
It’s as if my macbook doesn’t recognize the drive.

In my locations I can see ‘MyCloud-VH77Z5’ but it doesn’t connect.

Can you help me?