Cannot Uninstall Or Install WD Discovery

I have a WD Cloud Home Duo, which I was accessed through WD Discovery 2.2.408 with no problems. Suddenly this morning (24 March 2018), WD Discovery prompted me of an update, which I tried to download.

After downloading, it would not install. And my WD Discovery stopped working. I cannot access my Cloud Home Duo anymore.

I tried downloading WD Discovery again, but the newest version I could find was 2.2.408. Anyway, I downloaded it but it will not install. Whenever I tried, it just says that there was a newer version of WD Discovery already installed in my computer.

I have already deleted all WD software in my PC and yet it is still showing the same message whenever I tried to install. No WD software is showing up in my control panel programs because I have already uninstalled all of them (via the control panel).

I have also tried to delete .wdc in users/username/.wdc…but it keeps automatically appearing again whenever I try to reinstall WD Discovery.

Without WD Discovery now, I cannot access my Cloud Home Duo at all.

Any help will be appreciated, please!

Hi Andy4,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.

Hi Brandon.P,

Thanks for replying!

Yes I already have already contacted them. Case number is 032518-12825484.

The first reply they gave was just with instructions (and links) on how to install WD Discovery.

I wrote back to clarify the situation with them and still waiting for their second reply.

I had the same problem and had to use my IT experience to remove registry settings, as well as a number of WD / Western Digitl folders; this is very poor.

Thanks gerrylengthorn!

I am not an expert in IT stuff, but I did try to use Ccleaner to clean the registry. Still no go.

IObit (a third party uninstaller recommended by WD) also can’t find anything else to clean.

I guess I’ll have to keep trying…or worst case scenario, wait till the next WD Discovery version is released, then hopefully I can use it to override this current version.

WD is still not replying to my case…

1 Like

I spoke with support and they were useless. I rolled back my machine to before I uninstalled the Mac version of the software. It continues every few second to try to update itself and get in the way.

The software update needs to be rolled back or the notification to update stopped until they get it actually working.

Hello… I don’t know if you are still having this issue but I eventually figured out the problem and managed to get WD discovery to re-install in my MacBook Pro. I had the exact same issues as you and it took a few hours to realise the problem.
Firstly yes follow the online instruction and delete all WD files from hidden library on Mac. What they don’t tell you is you then have to also delete them from the system library folder!!!
In your Finder window under devices click on the name of your computer. Then click on your Hard Drive, mine is called Macintosh HD. Now you will see a few folders, one called users, one called library and system. It’s inside this library folder that there are still WD files which you need to delete.
Just go into library, spotlight search WD and delete all related files .plist etc. Do the same with the system folder.
Then reboot the computer and re-install, worked for me after hours of pulling my hair out…

Chris

Mine just went offline . Talked to a technician and he has no clue why . He said it’s a defective item and that I should send it back for a replacement. Of course I have to pay for the shipping and a third party to extract the data from the unit or lose my photos . Not cheap . I have a feeling that they are very aware that all these models are defective. Purchasing this product was a huge mistake . Case #13945863

I have just the same problem.

Imac OSX 10.9.5 tells me to update WD Discovery.
I download the latest version but installers exists in th emiddle of the installation.
I can see MyCloud but as guets only thus useless.

WD help please !
I