Update 4.3.327 don't work with mac high sierra and mojave


Thank you for sharing

Downloaded the full version
Uninstalled again the last version as before
Turned network to offline
Installed the full version
Turned network online
WD Discovery suggested update (NO WAY)
Logged in

Flowers back again!! :slight_smile: :grin:

Thank you Tekram

Note 1: iOS High Sierra 10.13.6
Note 2: Can WD support informe us when solution is found for update!?

1 Like

Like tekram wrote: https://downloads.wdc.com/wdapp/WD-Discovery-darwin-prod-x64-3_5_138_full.dmg


Like tekram wrote: https://downloads.wdc.com/wdapp/WD-Discovery-darwin-prod-x64-3_5_138_full.dmg :+1:t3:

1 Like

Nice tekram. That’s the one! Brilliant!

1 Like

Just had to create an account and share a “thanks” to @tekram for the link to the older version of the WD Discovery software.

Be sure to turn off:

Enable silent update

This setting selected will keep it from “silently updating” to the new version after the old version is installed. I installed the older version and then it immediately updated to the latest version!

Fool me once, shame on you, WD… fool me twice… ah ha, you didn’t, I caught it and it didn’t happen the second time. LOL

Old version works like a champ to put it back in Finder on my Mac Pro.

Nice update WD… almost had me ditch the whole MyCloud Home. Now we’re stuck on an old version because the new version is…


I am glad it worked out for many of you. For myself, I would rather wait unless the dust settles before jumping into any new version releases. You know the old saying, if it ain’t broke … :grin:


Sorry Tekram, it doesn’t work for me
I have an installation fail message.
Note 1: iOS High Sierra 10.13.6 and i did everything like Helder_Cardoso

Thank you so much

I’m in exactly the same situation as you - WD support asked me to check whether I was on M1 processor (our MBPs are a little tad too old for that kind of processor) and the instructions I was sent to further troubleshoot the issue aren’t relevant to our version of Mac OSX.

WD - please make available the version before this latest 4.3.327 update! Much appreciated :slight_smile:

@tekram solution worked here. Thoroughly uninstalled previous WD Discovery version. Downloaded and installed 3.5.138 version. MacOs High Sierra 10.13.6 running in an unsupported MacBook Pro 2009.

Thank you all.

Already this stuff is useless, no ftp no smb no afp no rtcp, the KDD process eats all the resources of the processor, now it is unusable because an update was written with the feet. Why did I buy this ??

Great Job! thank you

@faithw Fully agree. It’s too bad we have to go back to such an old version to get it to work properly again. If only we had known that doing the latest update would wipe the old version and break the functionality that worked so well before the latest update! – WD definitely should make available the full software downloadable instead of an installer that only can install the most current version.

@Miniroby - did you fully uninstall the newer version first? Fully uninstalling (and maybe rebooting the system) seems to be doing the trick to install the older version.

@WD_Admin Look at what your customers are having to do to bypass an issue with your software!

I was fully of hope but it does not work for me on Mac mini running Mojave.

WD has put out the installer for previously working WD Discovery version 4.2.288


Thanks @clementtan will revert back to this version and thanks @bombadiliosis for that hint of turning off “silent update”!

My first go at reinstalling the darwin-prod-x64-3_5_138_full.dmg worked and then auto-updated, causing the same issue again! #n00b

WD support came back to say that our issue is too complicated for email support and so suggested to call in. Will wait until WD release a more stable version of this update.

hei Guys, I’ve been communicatin gwith WD Support via Incident Tickets. Trust me USELESS, all I asked only give me full installation of previous version while they are working on th bug on this latest version. THEY CAN’T PROVIDE IT, RIDICULOUS!

And Finally, uninstall your latest WD Discovery, and download this



can’t find where to turn off the silent update. Please guide me