Unhappy with My Cloud - just want to use it as a dumb backup drive now

So I’ve tried it for a while and overall it’s more hassle than it’s worth.

I just want to use it as drag ‘n’ drop storage.

With that in mind, I’ve plugged it directly into my laptop via the ethernet cable and the laptop doesn’t see it. I’m guessing that’s something to do with the security built in with the software on my laptop.

How do I go about achieving my aim?

Somewhere along the line I will need to free up the space occupied on my WD disk, enable my laptop to see the drive, and remove the WD software from my laptop.

How do I do these, and in what order?

TIA

You’ll need to assign static IPs to both the laptop and NAS when connected directly. Or enable internet sharing on the laptop’s ethernet adapter to let it assign IPs via DHCP.

Why not plug in the NAS into your router? That’s how it supposed to be linked :slight_smile:

Because I just wanted a simple backup device - plug ‘n’ go, not faff ‘n’ bother.

It took me a while to get it ‘working’, and it’s just way too much effort.

Apparently this:

"You’ll need to assign static IPs to both the laptop and NAS when connected directly. Or enable internet sharing on the laptop’s ethernet adapter to let it assign IPs via DHCP.

 

Why not plug in the NAS into your router? That’s how it supposed to be linked Smiley Happy"

…Has been flagged as a solution.

Maybe it was me with ‘fat fingers’ maybe it was somebody else.

Either way, that isn’t a solution.

That’s how NASes works. I don’t see much effort, just plug it into the router, setup users/shares and browse the NAS shares, backup from/to the shares etc2.

If this is too much effort, the only solution is to get a refund and/or exchange for a foolproof external USB drive?

Hello JohnLG

So I thought I would give it a go at helping you.

Despite the ability to plug directly via an internet cable into your computer, you still need to do everything that you did before in setting up shares, Usernames, passwords etc., mapping the shares to a drive letter on the PC to access the shares on the Cloud. It won’t just show up as a hard drive like a USB drive would. The other difference is that now your computer is no longer connected to the internet, or if you are by using a second ethernet connection, then the Cloud won’t show up on the same network.

Assigning static IP to both devices is one way to get access but you don’t have to. If you left both devices, the cloud and your computer to dhcp, the default assigned ip to the Cloud is something like  “the (auto) IP assigned to MyCloud is 169.254.7.48.”

If you do managed to figure out how all this works by plugging it directly to your computer, you might surprise yourself, once you figure out all this out because the only difference between plugging the cloud directly to your computer and plugging the cloud into the router, is the IP.

Now having said all the above, you still might be better off in getting a USB drive since the speed difference is enormous. If all the options of returning or selling it are closed to you and you still haven’t figure it all out, you might try optionally to remove the hard drive from the enclosure and use a third party USB 3 enclosure instead.

By the way, you don’t need any of the software in order to access a mapped drive. Un-install all the WD software that you did install and just learn how to mapped your Cloud to a drive letter on your PC or map a volume to a Mac. 

Good luck…

Ralphael

One thing I have not heard about connecting the My cloud directly to the PC, is a crossover cable.  When you connect

the My Clouud to a PC with a normal cable.  You end up with rx to rx and tx to tx.  Becasue the pin out of both devices

is the same. 

RAC

You don’t need crossovers now a days. Most ethernet are equipped with MDI/MDI-X to do automatic crossover between two capable devices.

yes what Nazar78 says… no crossover cables needed these days for the Cloud.

JohnLG wrote:

 

With that in mind, I’ve plugged it directly into my laptop via the ethernet cable and the laptop doesn’t see it. I’m guessing that’s something to do with the security built in with the software on my laptop.

 

How do I go about achieving my aim?

Your problem is that your trying to use the My Cloud in manor it was not initially designed for. By plugging it directly to your PC the WD My Cloud will not obtain an IP address from the local network’s DHCP server. Because of this the WD My Cloud may auto assign its own IP address which may put it on a different IP address subnet from your laptop which means your laptop may not see or access it. No matter the case your unhappy with the drive because your using in a fashion it was not designed to be used as.

You have several choices. First and most obvious is to set the drive up as it was designed to be setup. Connect it to your router via the Ethernet cable/port so that it can obtain an IP address from the same IP pool your laptop is receiving then use the device as it was intented to be used (connected to your local netowrk). Second option is, if you can reach the admistration screen either while direct connected to your laptop or while connected to your local network, is to configure the WD My Cloud to use an IP address in the same IP range as your laptop. Then try connecting the My Cloud directly to your laptop via the ethernet port/wire and see if it can be accessed.

Thanks for all your responses so far.

I’ve just had an email from WD support, so I’ll give thhis a go and let you know how it works out for me…

Thank you for contacting Western Digital Customer Service and Support. My name is [Deleted-Privacy].

I received a message from the back office with the request to contact you.
I was not able to call you as we do not have a phone number of yours registered.

They state that you registered a message indicating that you want to use the MyCloud drive as a drag 'n' drop device storage. 
If you have connected the drive directly via a cable to your windows computer and the drive is not visible, then it also still depends on how the operating system is setup.
Please be aware that the drive will only be visible in the network section of windows as it is still a network connection that you are making to the drive.
You can check to see if the drive is visible in the network section of windows.
Click on start> Computer> Network
The drive should be listed under the category "Storage" in the network section of windows. Please right-click on the icon of the drive. You should now have the option to "Open".
Are you now able to access the shares of the MyCloud drive?

You do not have to have any WD software installed on your computer to be able to connect to the drive via windows explorer on a local network.
If you do not want to have any WD software installed on the PC then you are able to uninstall it.

If the drive is not visible or accessible in the network section of windows then we still need to further troubleshoot the issue.

At this point to further troubleshoot the issue it is advised to disconnect or disable any wireless connections you might have established on the PC before connecting the drive directly to the PC.

Once this is done it is also advised to check if Network discovery and File & Printer sharing options are enabled on your computer.

Click on start> Control panel> Network and Sharing center> Change advanced sharing settings> Home or work
Please have both the option for Network discovery and File & Printer sharing set to "ON" under the "Home or work section" and then choose Save Changes.

Click on start> Control panel> Network and Sharing center> Change advanced sharing settings> Public
Please have both the option for Network discovery and File & Printer sharing set to "ON" under the "Public" section and then choose Save Changes.

Please see if the drive now becomes visible and accessible in the network section of Windows.
Click on start> Computer> Network
The drive should be listed under the category "Storage" in the network section of windows. Please right-click on the icon of the drive. You should now have the option to "Open".
Are you now able to access the shares of the MyCloud drive?

If you could please also send me a phone number that you are available on, so that we can call you if necessary to further troubleshoot the issue.

Please let me know what the result is after running through these steps.

Sorry for the inconvenience.

If you have any further questions, please reply to this email and we will be happy to assist you further.

Whoopee! I’m a Happy Bunny!

This is the bit that did it for me -

Click on start> Control panel> Network and Sharing center> Change advanced sharing settings> Home or work
Please have both the option for Network discovery and File & Printer sharing set to "ON" under the "Home or work section" and then choose Save Changes.

Click on start> Control panel> Network and Sharing center> Change advanced sharing settings> Public
Please have both the option for Network discovery and File & Printer sharing set to "ON" under the "Public" section and then choose Save Changes.