Unable to map network drive

Help! I cannot map a public share on my WD network drive. I have tried using windows 10 and also WD Access. I click on “map network drive” and there is no response! Both these methods worked in the past?

Is the computer connected to the same local network as the My Cloud?
Can you access the My Cloud Dashboard using a web browser?
Can you access the My Cloud using Windows File Explorer?

I am having the same problem. Ill run down the list.

Windows 10 Home.
Netgear Nighthawk x4 Router.
I have a WD MYCLOUD 4TB attached to the router through Cat 5.

Up until yesterday I was able to access the WD MYCLOUD drive through File Explorer, through browser and through my smart TV Media Apps. I have not been able to map it.

I have another WD drive connected through USB on the Router.

I also have multiple laptops and desktops sharing on the Network. No problems.

Yesterday I installed a new VPN on my router. Switching from OpenVPN to PureVPN. At the same time the Router had a Firmware update available which I downloaded and installed. After saving and rebooting the router I wasn’t able to access any of the drives or shared Network computers.

I disabled the VPN, rebooted the router and was then able to access the MYCLOUD and other drives through the File Manager but not through browsers.

None of the drives show up when attempting to map the drives. I am unable to access the MYCLOUD through a browser. The MYCLOUD and other WD Drive go in and out, sometimes I am able to access through File Manager and sometimes (about 50% of the time) they are not seen.

When I attempt to Login to mycloud through a browser it says to accept my devices security certificate. When I attempt to accept the certificate by clicking on the link I get a 404 TCP Relay Failure.

I have attempted every fix I know and what I could find online to include (In no particular order):

Turning off popup blocking to accept certificates. And accepting cookies from WD. It will still not accept the WD certificate and gives me a timeout error.
Adding Windows 10 credentials for the WD MYCLOUD. Deleted Credentials
Several mapping workarounds. None of the drives show up in the Network box when I attempt to map them.
Allowing WD MYCLOUD in the Router Device Manager. It does show up in the router devices and is allowed, I disallowed it, re-allowed and rebooted the router. The WD is in the green and “allowed” even when it does not show up anywhere else. But the router says it is inaccessible.
I’ve done all of the other basic things, cleared caches, rebooted everything, changed cables etc.
I have gone through my AV and checked to make sure it wasn’t being blocked, it is not being blocked (BitDefender) but does give an inaccessible message.

Bottom line on my issue is the WD MYCLOUD is up and running. It is recognized by the router. It is intermittently accessible through the file manager. But for everything else it is “inaccessible” including through the WD MYCLOUD Login. So somehow the router is seeing it and allowing it through so I can access through File Manager but it is blocked for everything else.

And finally everything else on the Network is working fine, two Smart TV’s, two ROKU’s, two Ooma Telo’s, and several other pieces of hardware all work fine.

Obviously the problem lies with the router since it appears all your problems started when setting up the VPN and updating the firmware on the router. Make sure the VPN module is totally disabled within the Netgear router. Another troubleshooting step is to perform a factory reset on the router and reconfigure it from scratch.

I identified and fixed the problem this morning.

Yes, I didn’t mention. My error for not mentioning it. Hard reset back to out of box configuration was one of the steps I took. I did note the WD MYCLOUD has never shown up in the Network list (Box) when trying to map it. I have never been able to map it. It is also showing strange behavior. It disappeared off the File Manager and one of the Media Apps, but when I went into another room to check if it could be seen on another Media App it was accessible, all of the files could be seen but not retrieved.

The other thing is I have 14 different pieces of hardware linked to the router and all worked except two. The WD MY CLOUD and a WD Passport. The problem was identified by WD Customer Support in a thread all the way back in 2011 where it concerned Window’s 7. So this is the problem for a lot of Windows 10 users and I am sure to 99% this is the problem.

My WD Passport and WD MYCLOUD are both 4 TB. The reason they are going in and out is because when I attempt to diagnose I unplug one, plug the other in and back and forth, etc.

When I unplugged the Passport, the request for the security certificate went away and suggested the standard firmware update. This morning I plugged them both back in and that was it, they were both gone. That told me there was some sort of conflict. So I searched the support databases for a potential security certificate conflict. That is not the problem. They noted there is also no problem with a Serial Number conflict since they are unique.

The problem is a Signature Collision in WIndows 8 and Windows 10. Two or more WD Drives only need to be the same size drives to cause a signature collision. Windows XP automatically corrected the issue of Signature Collisions. Windows 7, 8 and 10 do not. in 7,8 and 10 it requires Disc Management.

To test the issue I unplugged the Passport and plugged in a SG 2 TB drive and both were visible. Two different signatures. Plugged the WD Passport back in and they both went away, one Signature, two different drives but both WD and both 4 TB.

Ran WD’s instructions on Disc Management and the problem is now fixed.

Here is the link to the WDCS for the fix in WIndows 7,8 and 10 from back in 2011 (For 7) and updated for Win 8 and then Win 10. . Click the link on the bottom for the OS and the fix is right there.

This may not be the OP’s fix but the OP’s problem is/was the same as mine and a lot of other people have the same problem with the same symptoms and behaviors. I only noticed there was some sort of conflict accidentally. And this morning. Had to be a conflict if I could unplug a drive and the other drive worked.


I am also editing to add this. I had thought one of the USB 3.0 ports on my Nighthawk was bad. SO I stopped using it and went to Cat 5 for the other drive. Turns out the port isnt bad, I tested it with a SG drive this morning. That was also caused by a Signature Collision. Had to be, because the port works with one WD and one SG drive but not with two WD drives.

The problem isnt with the Drives or Router, the problem is with Signature Collisions not being auto corrected in Windows since XP.

The answer to all the questions above is yes! I am using Win 10 Pro and I am using the newest access point from Xfinity. I have mapped drives in the past but now when I click on Map and public in WD Access nothing happens? This also happens when I try to map a drive from “this PC” in windows 10. I used to get dialog boxes that would open when I clicked Map a network drive but this no longer happens!?