Unable to connect to the firmware update server


#1

The WD My Cloud EX2 firmware update worked the first time I tried it a few days ago (updated to 2.10.310), but now, choose Settings > Firmware Update > Check For Updates and it says:

“Unable to connect to the firmware update server. Please check the network connection and try again.”

Settings > Network > Status indicates it has “internet access”, so it seems to see the internet ok.

Is there a way to fix this?


#2

Have you tried the simplest potential solution - rebooting the NAS yet?


#3

Alas, yes, several times in fact.


#4

I’m seeing the same. I wonder if the update servers at WD are down this weekend?


#5

I have the same problem.


#6

I think I figured out the problem.

At first it looked like doing a System Only Restore fixed this.

However, once I went through and turned off “public” on all the shares and made them all read/write from the admin account, it stopped working. Since I’m logged into the admin account you’d think it would amount to the same thing (except perhaps more secure), but apparently it’s not: When I turned “public” back on for the SmartWare share, it started working again. Problem solved.


#7

I’m still getting the “Unable to connect to the firmware update server” error. Any official response from WD?

Correction - mine is working now.


#8

Official responses from WD included:

  • drive reset (holding down the reset button on the back of the unit for about 10 seconds)

  • using a static IP

  • System Only Restore (Settings > Utilities > Restore to Default > System Only)

  • update the firmware manually


#9

hi gbeddow, so that basically means they are totally clueless. I’m getting closer to asking for my money back on this junk…


#10

I’m seeing exactly the same thing now on my EX4… I’ve tried reboot, reset etc. No joy.


#11

Seems to me that enabling SSH and/or port forwarding required for remote backup causes the problem. Similar firmware update problem both on My Cloud and MyCloud EX2 Ultra. Both stuck on 2.30.196


#12

Suddenly it has worked at least on the EX2 Ultra. Strange …
So I had to update the other one manually of course.