Can't Connect to Firmware Update Server

Hello,
My MyCloud firmware hasn’t been updated since May 18, 2018. I am running version 2.30.193. I am trying to update the firmware to the latest version via the dashboard https://prnt.sc/qqg1e5 I am getting an error saying “Unable to connect to the firmware update server. Please check the network connection and try again.”

Here are my network settings: https://prnt.sc/qqg2rz

Please help, thanks

1 Like

@mandala
You can download and install new firmware. Use this link.

Thanks for the link. I downloaded the latest Firmware for my My Cloud and my My Cloud EX2 servers. I see that the firmware file for the MyCloud EX2 is approx 100mb while the file for the MyCloud is approx 1000mb! Any reason they should be so different?

Thank you. I updated the firmware. After the firmware update completed, I tried to log into the device setup page at http://wdmycloud/ and received access denied https://prnt.sc/qrt9wj. Prior to the firmware update, I was not prompted to enter a username and password when accessing the settings. I tried to do a paperclip reset on the device, but I was directed to the same screen upon login and am still locked out. How do I access the settings page now? Fortunately I am still able to access the Files dashboard, but I’d like to check the settings. Thanks

Please disregard. I did a 40 second reset and was then able to log in to the settings page. Thanks for your help! :slight_smile: