Unable to connect to the firmware update server. Please check the network connection and try again

My Cloud EX2 Ultra, I’ve updated to the latest firmware and changed it multiple times with the same error as in the topic. Has anyone seen this error and know how to get past it in order to upgrade to OS5? I can access all functions except the one to check on firmware. Thanks

@DJFinale What firmware version is your My Cloud EX2 Ultra?
You will need to install 2.41.106 to update to My Cloud OS 5 Pre Release. Details are located in the Announcements Section Announcements - WD Community

I have done that multiple times. That’s when the error occurs. It works with the previous install. The new downloaded binary upload installs successfully then gives that error.

The option appeared late this afternoon.

Thank you

I have tried several times and connected via the dashboard, but it always at the download. Is there another way to download the OS without going through the dashboard

new link appeared on dashboard this afternoon. 2 tries to download and then successful. Installed and working