Unable to access firmware update server

Just about to update to OS 5, having checked early November and seen the “New OS” box.
Today, when I opened the My Cloud Dashboard, I did not receive the “New OS” message.
Whe i clicked on the firmware box, the system said “retrieving”, and then displayed a message:
Unable to connect to the firmware update server. Please check the network connection and try again.
The network connect is good. I regularly back up to it every night.
So, I rebooted my router, and the EX2 Ultra, and tried again.
I received the same response.
I checked the message and this is what it said:
Downloading Firmware Update
Downloading firmware update.
Thursday, 2020 December 03, 0:00:02 Code:2024
I have searched the community site for Code 2024 and saw one unresolved mention fron Feb 2015.

Can anyone help?

John

Hello John,

sorry, I have no solution (yet?). But as due to many postings regarding the OS 5 update I am quite reluctant to going ahead and updating without more specific prior information on particular points, I have contacted the WD support on 6th of December. I couldn´t find reliable information on these topics anywhere, so I sent the following (text to send was limited to max. 2000 characters, therefore the short style):

While pondering updating to OS 5 now, I found that
a.) ‘invitation’ message to update to OS 5 doesn´t show on Dashboard. On clicking “search updates” button on Dashboard, it says “Unable to connect to the firmware update server. Please check the network connection and try again.” Tried different times of day and different days, always same result. This way, I can´t even update to 2.41.116 (have by purpose not checked on manual update).
b.) box will neither relent to a click on Dashboard restart button nor go for a nap on hitting the ‘standby’ button on the Dashboard (I could at least effect a restart on this box long time ago).
c.) in Dashboard network menu: “IPv4 IP-Adresse LAN1 Disconnected”. (I´m not sure if this one has ever been different though.)

Already pulled the box´s power plug and waited for 10 min before reanimation, but nothing seemed changed either. Also tried with static IP (i.e. on box, I never changed static IP assignment on router) and router restart.

I should be very grateful, if you could answer following questions:

  1. Concerning a.):
    1.1 Is this wanted?
    1.2 If not wanted, might this issue be solved after a given time without further doing of myself? As I don´t have use of web access, from my side I could easily afford putting off the update to OS 5 for a couple of months.
  2. Concerning b.):
    2.1 Do you recommend reset of box before updating firmware so as to solve this issue? If so, ‘4s reset’ or ‘40s reset’?
    2.2. Do you recommend update to 2.41.116 before updating firmware to OS 5?
  3. Concerning c.):
    3.1 Is this normal?
    3.2 If not normal, can you advise a way forward to solving this issue or provide some possible causes coming to your mind?

The answer I just got now reads:

Do you recommend reset of box before updating firmware so as to solve this issue? If so, ‘4s reset’ or ‘40s reset’?

Answer is YES

Do you recommend reset of box before updating firmware so as to solve this issue? If so, ‘4s reset’ or ‘40s reset’?

Answer is NO

Requesting you to please refer the below link:
https://support-en.wd.com/app/answers/detail/a_id/29383

If you have any further questions, please reply to this email and we will be happy to assist you further.

You can also contact us through Live Chat support by clicking on this link

I will go on trying and keep you informed in case I will obtain something rational. :roll_eyes:

Thanks ichbeans,
Coincidence, or what but I just checked and ai have 3 messages on my box.

  1. At 3.00.52 10/12/20 - Installing Firmware, Code 2026
  2. At 3.01.58 10/12/20 - Firmware install successful Code 2004 - V2.41.116.1117.2020
  3. At 3.04.05 10/12/20 - New My Cloud OS 5 Available!!! Code 1012 but no more updates until I do.
    All this within hours of putting in a support call to WD.

I guess the firmware update did the business but how did I receive it if I couldn’t contact the Firmware UPdate Server!!

1 Like

Hi John,

thank you for the information. I decided to wait a couple of days to see if time works for me, too. Well, it didn´t. I sent a reply to the mail I quoted in my post from 10 Dec to WD Customer Support, asking for a more useful answer anyway some days ago. I got no answer yet.

I wish you a happy Christmas time!

…and a Happy CHristmas to You too ichbeans.

John

This is how the story ended with me, for those as fell victim to the same EX2 Ultra vagaries and were let down by the customer support:

I still got no answer from WD Customer Support to my second request yet. Meanwhile I sent another request to the Support in my mother tongue. I got an answer there, but also to no avail.

A couple of days ago however, a fuse blew due to a defect kitchen appliance, which cut the power supply to the EX2 Ultra. The same happened a second time, just two minutes later. When again I readjusted the fuse, the EX2 Ultra rebooted and lo and behold, it established an internet connection all by itself. There was a message saying there is a new firmware update available (namely 2.41.116). What is even more, the until then missing IP addresses were displayed and the ‘IPv4 IP-Address LAN1 Disconnected’ message was gone. My luck however was not long for this earth: After some time, probably an hour like, my beloved ‘IPv4 IP-Address LAN1 Disconnected’ message showed again.

Miserable, cold and hungry, I then resolved to make my final stand by a 40 seconds hard reset to factory defaults as described here:
Hard Reset
After that an internet connection was established again and an update was found without further doing of myself. With the courage of despair I boldly pushed the update button in the Dashboard, three times clicked my heels and believe it or not: the update was successful, and the EX2 Ultra had an internet connection – again! Furthermore, the ‘invitation’ message to update to OS 5 displayed for all to see. Though I could hardly believe my good fortune, I felt the blood rushing through my veins again and, intoxicated by success, I once again hit the update button in the Dashboard, feeling like a cracked gambler. I started breathing again when the update was finished successfully about 5min later. The EX2 Ultra is running happily for one day now and I have not found any sign of trouble yet. It seems to be working as it ever has during the last year, which would be fine with me. And already I managed to unclench all my cramped toes right now. Happy Christmas! :joy:

At last, Ichbeans!
I, too, have upgraded to OS 5 successfully and all seems to be running great.

I wish you a Happy New Year, and a better 2021.

John

Thanks John, the same to you! It has been a pleasure. Take care. :grin:

Kind regards

Marco