Unable to connect to my cloud mirror

just bought a new my cloud mirror, the front panel’s power and drive and back panel’s ethernet led all are normal, after finished setting the My Cloud and sign in with problem and the warning message is

Can’t connect to my cloud mirror
Here’s what you can do and try and fix the problem:

  1. make sure your device is powered on connected to a net work with internet access. (as mentioned above all led are normal)
    2.update my cloud firmware. You’ll need to this from the device dashboard (web interface) under setting.
    If you still can’t connect to the device, contact WD support (today is a holiday)

Anyone can help to fix this access/connect problem

Thank you very much

Hello, you can try to manually access the dashboard by typing http://mycloudmirror in your browser and this should take you to the dashboard. Also I believe that WD Support is available today.

Hi, Thank you
Contacted WD support on yesterday and resolved.
Solution is blank the password then can access the dashboard, and doing the same all the time now, really confused.

anyway, thank you

Same here…unable to connect via WD’s ‘MyCloud’ portal but I can access my Dashboard, which tells me that my drive is online. My WD nightmare continues, had nothing but trouble with these devices for the last 6 months…
I am also able to access my drive from my iPhone via the My Cloud app and WD Photos.
I am irritated!

Same problem today, unable to connect mycloud.com whereas 2 phones are working fine !!!

Just purchased a 2t mirror drive and I can access via phone and tablet whilst on the same home wifi network but no access via second home network or remote over the web. Help pages seem particularly unhelpful.
Any ideas how to get it to work or do I just return it at not for for purpose under web purchase consumer rights and try something else ?
Not happy that the out of box solution failed on first try and others seem to have had problems.
Firmware is to latest as listed in help pages.
I’ll try phone support tomorrow and then return it as I have better things to do with my time than scanning the Internet to get a brand new expensive piece of technology to work as promised.

Same as my problem, once you get the code in cloud access in dashboard, it will work but half day only, I got the code 3 times and the last time had enter the code on my phone to activate and cloud access in dashboard indicated my phone is connected, unfortunately, it worked for half day only.
I believe it is not my set up problem, I called the WD support team twice before on this problem, they told me the usage of this code and no need to enter the code on my phone if I able to access from the cloud app, anyway, it worked for half day, even enter the code on my phone it worked half day same.
I lose confidence to retrieve data from this gear on street, I am very disappointed it failed on these basic function and give up it to use this gear for backup purpose only, it is easier for me rather to backup data on 2 different hard drives before. I consider to buy another NAS likes Asustor or Syngology, may extract the 2 harddisk to use in the new NAS !!!

This answer works for me.