Unable to Access MyCloud from Browser

Anybody here experiencing the same as me? I still can access via Android App and iOS App.


More information is needed. Cannot access what with a browser? The Dashboard, the MyCloud.com web portal? Have you tried the WD My Cloud Desktop program? When connected to the local network the My Cloud is connected too have you tried using the IP Address for the My Cloud in your web browser? When connected locally can you access the My Cloud using Windows File Explorer or Mac Finder?

Cannot access with any browser. I can access Dashboard. Don’t know of a MyCloud Desktop program. Will look into that. Thanks. I think it could be a networking issue. At the moment, I am able to access via my own lappie. Office desktop however is another matter. therefore I conclude that it could be a firewall issue. Previously I could access from office desktop. The IT administrator might have changed the settings.

Thanks for your reply anyway. Cheers.

If you can access the My Cloud Desktop with a web browser, then check to ensure Remote Access is enabled on the Dashboard > Settings > General screen and that it indicates has established a connection.

The My Cloud Desktop program for Windows or Mac can be downloaded from the WD Support site: http://supportdownloads.wdc.com/downloads.aspx

There is also the WD apps for iOS and Android that can be downloaded from their respective App Stores.

Noted with thanks.