Can't access MyCloud

I’m running into a stalemate in trying to access MyCloud files, both on my PC, where my WD device is located, and remotely at another computer. Is anyone experiencing the same issue?

More information is needed to assess what your issue might be. What specific My Cloud model are you using? What troubleshooting steps have you tried? What computer operating system (or mobile device operating systems) are experiencing the problems? What specific error message are you receiving? How are you trying to access the My Cloud (Windows File Explorer, Mac Finder, other)? Can you access the My Cloud Dashboard? If so what does the My Cloud Dashboard > Settings section indicate for Remote Connection Status? If having trouble with remote access, have you tried a different web browser or disabled any browser add-on’s/extensions? If using security software on the computer has it been disabled as a troubleshooting step to see if it is intefearing with My Cloud access?

Currently no issues accessing a local network single bay My Cloud using Windows 10 (with SMB1.0/CIFS enabled), nor do I have issues accessing two separate single bay My Cloud models using web portal.

1 Like

I had the same problem yesterday morning when I tried to view a file on my 1st generation WD MY CLOUD while away from home. I was able to view the file on my 2nd generation WD MY CLOUD.

I was using my new Samsung Galaxy S20 5G phone.

Maybe its a problem with just the mobile app. So far no issues with when I checked this morning (at the time of my earlier post), but on the Android My Cloud OS3 app right now (as of this posting) it fails to connect to either remote My Cloud that I have access to. Both are first gen v4.x units.

Edit to add: The one first gen I have access to, the My Cloud app (remote access) started working again once I did the usual turn off remote access, wait a few minutes, then reenable remote access in the Dashboard. Personally I rarely use the WD methods of remote access, preferring instead to use other methods (VPN) when I want remote access to my My Cloud device.