Computer can’t access My Cloud

I have been trying to connect with My Cloud for a few days now. I also can not connect with the dashboard. I tried to connect directly to it with the Ethernet line as support suggested with no results.
Anyone with this problem or a fix?

@Mkciechowski If you are trying to reach have you tried a different browser?

To open the Dashboard what have you tried so far? What device and operating system are you using? If you have Windows 10 open File Explorer then click on Network and right click on the device and click on View device webpage.

Also if your device is showing under computer then click on that and you should see all your shares.

Thank you but my computer will not acknowledge my cloud exists. I can not connect with it or the dashboard.
When I look under file management the my cloud is not there anymore.

1 Like

If you have connected your My Cloud (Not My Cloud Home as that is a different device) to your local network router and the My Cloud has a blue front LED, access your router’s administration page to see what IP address the router has handed out to the My Cloud.

Use that IP address to access the My Cloud in Windows File Explorer (or Mac Finder). Example: \\

If you are running Windows 10 note that Microsoft may disable SMB 1.0 which causes problems trying to access the My Cloud. The following WD Support article explains how to enable SMB 1.0.

Also if using Windows 10 make sure Networking Location is set to Private and not Public.