Cannot connect at all to my dashboard

I’m still unable to connect at all to Mycloud’s dashboard, so I’m still dead in the water. I just started File Explorer. I let the computer build the “network” and it did so correctly. Under “computer” It shows my desktop and my Mycloud. It shows Mycloud under “Storage” and under “Media Devices”. In the past, when I’ve clicked on Mycloud under “Storage” it has quickly and seamlessly launched my dashboard. This morning, all i get is a totally blank page with “connecting” at the top in the tab label in Firefox and the incessant progress wheel whirring around endlessly and nothing more. In this blank page, in the URL window appears my IP address This has remained unchanged since I first set up the device a few weeks ago. I know almost nothing about IP addresses, however, so I have no idea at all if this is part of the problem or part of my solution!

Why can’t I connect to this thing? Do I need to do a “paper clip” reset? If that’s what I need to do, I will, but why should that be the solution? Why should it so often be necessary to in essence tell the device to just start all over again?

ps: The “connecting” page is still blank and the progress wheel is still rotating, with nothing else happening.

More information is needed. How are the My Cloud and the computer connected to the local network? Is your broadband provider AT&T Uverse? Are you using Windows 10?

If using Windows 10 see the following link for various things to try including making sure NetBIOS over TCP/IP is enabled, the computer is using the same workgroup name as the My Cloud, that the network is configured for Private, your firewall isn’t blocking access.

If you want to reset the My Cloud (40 second reset) then see the following WD Support document for more information on using the reset button on the back of the My Cloud.

I would initially try the paper-clip reset and go from there.

The reset is often the solution , because that’s technology for you , a lot of items just need resetting when they have issues.