My Cloud cannot connect

I read a post on this topic and got some good tips. Seems the original problem was never resolved. That’s my case as well.

My MyCloud used to work. Now it doesn’t. Dashboard does not connect.

I’m using a PC, Win7.

  1. I pinged wdmycloud and that worked and reported the ip address as
  2. I pinged and it worked.
  3. I checked under Printers and Devices and found the MyCloud. Under “Properties/General” it says - Currently, this hardware device is not connected to the computer. (Code 45)
  4. The LED on front is blue, but somewhat faint.
  5. I reset it several times. During reset I can feel the head is moving. At some point the LED goes yellow then turns off, and eventually blue.
  6. I did the factory reset, too.
  7. My Dashboard shortcut uses the correct IP address
  8. The ethernet LEDs on back flash, so I have a connection.

My setup is an ATT Uverse modem/router that connects directly to two PCs and a switch. The My Cloud is the only device on that switch.

Any suggestions?

Update: I can access my files using Explorer.