Help needed to get My Cloud working again after moving house

Hi, I’m having problems connecting to my My Cloud and was hoping someone here could help me please?

I used to have My Cloud set up great on my network in my old home, but recently moved and after taking a few months to fix the place up a bit, I’m now trying to set it all back up again but am having a few problems.

When I open Finder on my Mac, I can see My Cloud listed in my Networks on the left pane. I click it and it says “connecting” at the top of the window, then either fails to connect completely or will connect and show the folders but then when I try to browse the folders, it stops working and freezes up. Eventually I get a connection error message come up and then I am unable to connect to it again until I have power cycled both the mac and the My Cloud!

One thing is different about the setup now and I’m not sure if it is what is causing the issues but
in my old place I used to have the My Cloud plugged directly into the router via ethernet cable as the place was small and the wifi signal reached every room. In the new house, the walls are a lot thicker so we have the router in the basement, where the phone socked comes in then a mesh network set up to extent the signal to the rest of the house. I now have the My Cloud plugged into the main node of the mesh via ethernet. Is this what is causing problems?

I tried plugging the My Cloud into the router with an ethernet cable, but because the router is set to just forward traffic to the mesh node, I’m not able to connect to My Cloud at all.

Can anyone help please?

Which specific My Cloud device do you have?
Can you access the My Cloud Dashboard?
What color is the front LED?

If you previously configured the My Cloud for a static IP address you may need to access the My Cloud Dashboard > Settings > Network and change it back to the default of DHCP. Or perform a 4 second reset to reset the administrator name back to default (blank) and reset the IP address back to DHCP.

Having the My Cloud connected to a mesh node could be an issue depending on the mesh network configuration. Normally in a mesh network there is a main router/gateway from which the mesh nodes are connected to. Try connecting the My Cloud directly to the main mesh router/gateway and not the mesh node. Usually the main mesh router/gateway will have one or more Ethernet ports for precisely this purpose.

In rare cases a 40 second reset can fix weird issues on My Cloud devices.

Single-Bay My Cloud OS 3 Dashboard Access

Pin Reset and System Only Restore WD My Cloud OS 3

Hi thanks for the reply.

I have the My Cloud 4TB (running Firmware Version 04.06.00-111). The LED is blinking orange.

I am able to access the Dashboard after a really long load time, but if I try to change anything or view users etc. then the page will freeze and I won’t be able to access it again until I reboot it.

I meant the gateway instead of node, sorry I misspoke.

I’ll just try the 40 second reset I think, it seems to be the “cure all”

Thanks for the reply and info :slight_smile:

Quick follow-up to this problem…

I carried out a 40 second reset. Waited about 20 minutes, then tried connecting to the MyCloud using the mycliud.local shortcut I created previously, but get an error saying the server can’t be found.

I tried the IP address that I knew the device used to use. The page loaded and I saw the screen where I have to agree to the End User Licence. I agreed, clicked continue and saw a little grey UPDATING box and the page continued to load. I waited a while and the page refreshed but now all I can get to load on this page is the WD My Cloud logo. Nothing else loads at all! I have tried a few different web browsers and I get the same ossue on all of them.

I’m not sure what to do now. Can you offer any more advice, please?

Have you tried rebooting the My Cloud? Have you tried doing a 40 second reset a second time? Is the My Cloud directly connected to the local network router/gateway? Is the computer you are using to setup the My Cloud directly connected (preferably using Ethernet wire) to the same network router/gateway?