Unable to access GUI


Can not access GUI unless I power cycle. Ping works fine and I can access the folders on the internal and USB attached external drive.


Is your device set up for local use only? Have you turned off internet access? Have you given your device a static address?

If by “GUI” do you mean the My Cloud Dashboard?

How to Access the Dashboard on a My Cloud (single bay) Device

The Usual troubleshooting steps apply:
Reboot the My Cloud.
Try a different web browser.
Temporarily disable any third party security, firewall or anti virus software.
Is the front LED on the My Cloud blue or red? If red, that signifies a possible problem with the drive or the operating system.

A 4 second or 40 second reset may fix certain access issues.

How to Reset a My Cloud (single bay) Device

Thank you for the reply cat0w. Yes, I have internet access off and I also have it turned off in my Asus router for the static IP address I use for the device. The only way I can get back into the units “My Cloud Dashboard” or GUI is to reboot the unit by unplugging it and waiting for the drive to spin down and plugging it back in.

Thank you for the link Bennor. The next time it wont let me in I will try the “http://wdmycloud/” URL instead of the IP address and see what that does. I have not the resets many times and while that fixes it for a short time the problems always seem to come back. It all seems to have started with the v04.05.00-353 firmware upgrade… almost like WD wanted it to start acting up so I would upgrade to a new model :thinking:

I did notice that a new Firmware has been released “v04.06.00-111” so I just installed it and then turned back off internet access on my router and the internet access on the device itself has been removed so that is a plus. I hope that maybe this latest version fixes the issues I have been having since v04.05.00-353.

One last think, I read something about Twonky maybe causing an issue and that you can disable it?

If you want to disable Twonky, see the following WD Support Knowledge Base Article.

My Cloud OS 3: How To Disable Twonky DLNA Media Server

Disable Twonky DLNA Media Server

Follow the steps below to Turn Off Twonky DLNA Media Server for all My Cloud content.

  1. Click the Settings tab

  1. Click Media

  1. Turn OFF Media Streaming to disable

1 Like

Thank you again Bennor. I thought that might me it and I always had that disabled as it really slowed the unit down when it was enabled.

Here is an image of my old WDMYCLOUD. The top two icons open my dashboard and my public folder. I haven’t had any problems with mine since I set it up for use on my home network. My address to open the Dashboard of mine is shown under Properties.

Thank you for that cat0w. Can you tell me what firmware version yours is running?


1 Like

Thank you for that. That is the version I was having issues with. I have since updated to the latest firmware and swapped out the Cat 5e cable with a Cat 6 and changed ports on my Asus router for the WD device. Will see what happens now! :crossed_fingers:

Same issue this morning. I can ping the unit just fine. I can access all the folders of the unit in Windows Explorer just fine, it shows up under “Storage” in Windows explorer, but I can not access the Dashboard at all using the static IP address or using http://wdmycloud/

I have to power cycle the unit in order to gain access to Dashboard. I guess my unit is on its deathbed?

What error message is the web browser showing?
Are you running any browser add-ons that may impact loading web page scripts? If so temporarily disable them.
Have you made any previous unofficial modifications to your My Cloud using SSH?
If you have a Ethernet port on your computer you could connect the My Cloud directly to the computer’s Ethernet port and then try to access the My Cloud Dashboard.

How to Access a My Cloud When Connected Directly to a Computer

Thanks for the reply Bennor.

1: Same as in my first post above: “This site can’t be reached”, Power cycle of WD unit fixes the issue.
2: No. and it gives the same error above in Chrome or Edge.
3: No.
4: I will try that next time it will not let me access Dashboard.

I’m also not able to access to Dashboard. My Cloud has old version of firmware (FW3xxx).
I made a >40s reset, then the tutorial stoped here:

I couldnt click to cancal. If I click to refresh, I red error message appiert for a very short time: The user name or password entered is incorrect Try entering it again, than I see only this page:

The SSH, FTP access are not work but SMB sharing working, I can see my backup files on the nas.

How can I get access to GUI/Dashboard?

You have a first gen single bay My Cloud running OS3 v4.x firmware. Try doing a 40 second reset again using the method WD recommends:

My Cloud OS 3: 4 & 40 Sec Reset (System Restore Only)

One can try a firmware update/reload using SSH to see if that fixes the issue. For first generation single bay My Cloud’s:

How to upgrade from firmware file using SSH (v4.x)

Connect to My Cloud using SSH.
Change to the Public folder: cd /DataVolume/shares/Public/
Download the firmware file: wget http://download.wdc.com/nas/<name of firmware file>
Extract the firmware file: unzip <name of firmware file>
Issue the firmware upgrade from file command:
/usr/local/sbin/updateFirmwareFromFile.sh /DataVolume/shares/Public/<name of extracted firmware file>

After My Cloud reboots post firmware upgrade one can remove the firmware upgrade files from the Public folder using Windows File Explorer or Macintosh Finder. Or one can issue the following commands from the Public folder using SSH:

rm -f <name of firmware file>
rm -f <name of extracted firmware file>

As always, when using SSH one proceeds at their own risk!!!

As I remember it has FW: v3 NOT v4 and the SSH setting is disabled by default.
I tried the 40s and the 4s reset but I have same problem like before.

After the 40s reset I have this page:


and now I have empty page as before.
Do you have any idea how can I solve this issue?

Your screen captures indicate v4.x firmware. the v3.x firmware had a dark colored background. Example of v3.x firmware My Cloud Dashboard:

What color is the front LED on the My Cloud? Blue or some other color.

As a troubleshooting step, if you haven’t done so already, try using a different web browser to access the My Cloud Dashboard.

As a last resort on one could try one of the first gen single bay My Cloud unbrick methods to see if they can regain full access to their My Cloud. One can search the subforum for various discussions on how to unbrick the first gen single bay My Cloud.

The LED is blue.
I already tried from PC, tablet, mobile and Safari, Firerox and Edge.