Two MyClouds on one network?

Title says it all. I’ve read all the posts on this forum - half say it works fine, half can’t get it to work. If I disconnect one of the MyClouds, the other connects just fine with port forwarding enabled (no relay connection, no failed connection). When I connect the other one, the first becomes a relay connection and the second connects only intermittently (mostly failed). They are a 2nd gen MyCloud and a first gen MyCloud mirror, different names, different reserved IP addresses. UPNP setting on the router identifies 4 port connections when both are connected and 2 connections when only one is connected (one internal, one external).

Is this a MyCloud issue, a network issue, an ISP issue (the fact that one connects fine and two connect intermittently suggests its not the ISP blocking ports).

I have two single bay WD MY CLOUDS, a 1st and a 2nd generation, and both work fine. They are connected to my Linksys Router, MU-MIMO. Who is your ISP? How many devices are on your network? What type of router do you have? Have you looked at the Learning Center and the User Manuals for each device?

image

Are both devices in the same workgroup and have their own Mycloud.com Account? Click on, tap or activate images to enlarge them.

Thanks. Yes to all of the above. I can see the drives on my internal network, like you - it’s web access that isn’t working.

Can you post your router’s UPNP settings/port map table?

What do you have setup in the Dashboard under Settings>General>Cloud Access, Configure, for each device?

Automatic, just like yours. UPNP opens ports 80 and 443 when only one cloud is attached.

I have two mycloud type devices.

I have gotten them both online (before I decided that security wasn’t adequate, so I blocked them)

The key here lies in the router.
By default, both devices will attempt to listen to the same external ports. . .that won’t work well; and the devices/WD servers will get confused.

Looking at my notes; I did it two ways: I set external ports on the WD mycloud AND also did it on the router. I suspect you can make it work by setting it in one place; but I had it set in two places

Setting it up in the router, you need to two things; First, you need static IP addresses for your MyClouds. Second, you need to go into the “Port Forwarding” table on the router and assign different external ports for the two myclouds.

For example, my table looks something like this

External port - - - IPaddress - - - Internal port
8083 - - - - - - - - 192.168.0.1 - - - - 80 <for my cloud #1
8444 - - - - - - - - 192.168.0.1 - - - - 443
8082 - - - - - - - - 192.168.0.2 - - - - 80 <for my cloud #2
8445 - - - - - - - - 192.168.0.2 - - - - 443

In the MyCloud, I used “Manual” for connectivy options.
In one device, assigned the HTTP to 8082; and the HTTPS to 8445
In other device assigned the HTTP to 8083; and the HTTPS to 8444

Hope this helps.