Trouble Accepting Security Certificate through MyCloud.com

When I log onto MyCloud.com and try to access the My Book Live, it tells me to accept my devices security certificate. When I click on the link, it returns a error saying that URL was not found. I can still access it remotely from my phone using the My Cloud app. I checked and the firmware is up to date as of 10/30/2015. Any ideas on how to get to the certificate so I can accept it? >

<img src="//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/wd/original/3X/1/6/1684a9c9d716e69fcafbffc654fbe8f86fbe7c5a.png" width=“690” height=“208”

Hello there,

Have you tried to see if on the desktop app the drive is available?

I am having exactly the same problem. I can access the drive from home through wd quickview, but I cannot access the drive remotely through wd2go or mycloud.com, I get the exact same screens as above. Any ideas?

exactly the same here

same here

Same problem for me…

same here. But the link worked when I changed browsers. So you might try doing that. Also check if pop ups are disabled. If so, enable them just for this.

I am having the same issue with my My Book Duo 8TB (4TB). I have others and they are all working fine. Has anyone gotten it to work. I have tried on all the browsers and same error.