Cannot accept security certificate

I am very fed up with WD my cloud product, it has taken me 3 hours and i cannot set this up.

  1. i cannot connect using android app to the my cloud drive, citing connection error 906. i looked through troubleshoot and the forums and found no solution to this.
  2. i cannot open with mycloud.com login portal, it says i need to accept ‘your devices’ security certificate’. however, once i click the page it says the below (for all chrome/firefox/IE)

i look forward to getting a response from the WD team with regards to their product being ultra user-unfriendly.

This site can’t be reached

(removed for privacy potential issues)xxxxxxxxxxxxxxxxxxxxxxxxx.wd2go.com refused to connect.

Try:

  • Checking the connection
  • [Checking the proxy and the firewall]

ERR_CONNECTION_REFUSED

Not your fault, mostly this happens when mycloud.com is down which happens very frequently. See here You may complain to WD but they don’t care.

@s03328 Is this the device you own? WDMyCloudImage

To check that and disable this option, you have to right-click Windows key and open Control Panel. Select internet options and open advanced tab!

yes i bought a WD my cloud device, i have renamed it to my own nickname as well, but don’t think that should affect anything…

@s03328 Look at this information and the links for both generations User Manual.

https://support-en.wd.com/app/products/product-detail/p/126

I just signed into mycloud.com and I can open and view both of my devices. I have a 1st and a 2nd generation WD My Cloud.

Have you already set up everything in the Dashboard? Be sure to read all Help information that is provided.

i have looked into the user manual/support site and found https://support-en.wd.com/app/answers/detail/a_id/4305/kw/security%20certificate, however the solution doesn’t work and im still getting the same error.

I have also tried the solution suggested above of turning off the warning “Warn about certificate address mismatch” in control panel however this doesn’t solve the problem either.

i have even tried to disable my antivirus program but it doesn’t help either.

Any other suggestions would be greatly appreciated.

Thanks

I too am having this issue. Is there any update?