Remotely access my cloud

My computer is a macbook air running catalina and iPad Air using iOS 14.

I was away from home recently and was unable to log in to my “my cloud” server. I used the web site and used my usual password and was not able to log-in. I received an error screen that said among other things “accept your devices security certificate”. Although I clicked on it nothing changed. I also tried the “My cloud OS 3” app on my iPad and the icon just spun.
Its been a while since I tried to access it remotely but it had worked fine in the past.

I also tried sending a link for a folder on the drive to someone and they received the same error screen that I saw trying to login remotely.

Appreciate any advice.
Thanks for your help!

First troubleshooting step (requires local network access to the My Cloud) is to turn off remote access/cloud access in the My Cloud Dashboard > Settings. Wait a few minutes, then re-enable it. Then see if the issue persists.

Generally one can accept the security certificate and gain access to the My Cloud when using the web portal. the method for accepting the certificate may vary between web browsers. Here is how I did so using FireFox that was posted to another discussion a few months ago .

I’m not even getting to the second page. Once I click continue it just opens a new tab that keeps loading. Any other way that this can be fixed?

Try a different web browser. Also, disable any extensions or add-ons in the web browser as a troubleshooting step. Also disable any security programs or ad-block programs (including things like Pihole if using it) as another troubleshooting step.

Currently no issues on a Windows 10 PC using Firefox to access several My Cloud devices using the web portal.

Tried that before asking. Firefox is a fresh install too so no extensions/add-ons.

I’ve checked the settings on my Dashboard as well and all looks good. Tried the Accept Security Certificate link again after 12hrs and still the new tabs just keeps reloading/retrying without going anywhere. Man this is frustrating. The android app is not working for either. I feel like I’m missing something…