Mycloud.com can't connect to MyBookLive

Hello. I recently bought a 3TB My Book Live. My problem is I can’t connect to it thru mycloud.com or wd2go.com using a Windows 7 PC. I can access it locally using Windows Explorer. I can also access it on my android phone using the MyCloud app. When I try to connect to it from mycloud.com using either Firefox or Chrome, I get this screen:


I verified I can connect using my android phone and I have updated the firmware to “MyBookLive 02.43.10-048 : Core F/W”. So I click the “Accept your device’s security certificate” link. I then get this page:

What am I missing?

Try clearing your cache and navigation history on both browsers in order to accept a new certificate.

Same problem. clearing cache doe not help. VERY frustrating.

I’m also having the same problem. I accept the exception and then it gives me this error message: “The requested URL /test.html was not found on this server.” I’ve tried on multiple browsers, same result.

I have the most up to date firmware and the device is on. In the dashboard, Remote Access --> Configure --> Remote access is enabled and connection status is Connected. However, when I go to MyCloud.com, it displays the same message as above about steps 1-3, I see My Book name, however when I click the settings icon, it says the book is offline?

Any suggestions? Thanks

Still having the same problem, any recommendations out there?

Has anyone successfully connected and accessed their My Book Live from MyCloud.com?

Same problem. I have access from mycloud app on android and Windows 10 mycloud app on pc. But getting no access from mycloud.com on any browser from any device

I have. Clicked on highlighted Area in message