Transfer files from android to my cloud over a LAN

Is there a way i can transfer files from my android device to the My Cloud over a LAN. The My Cloud app seems to use the remote access feature resulting in extremely slow transfer rates. I have enabled FTP on the My Cloud and can successfully login using FTP from a PC but i can’t FTP into the My Cloud from my android. I have tried using different FTP apps but none of them will connect to the My Cloud.

Any help would be greatly appreciated.

Solved Please ignore.

Please post how you “solved” it for others in case they have the same question.

To answer the OP’s question, yes one can transfer/copy files from their Android device to the My Cloud on the local network (local LAN). There are several ways to do so. One is using the WD My Cloud for Android app. Within the WD My Cloud for Android app there is the option to upload files from the Android device to the My Cloud.

A second way is to use a File Manager app on the Android device like ES File Explorer app. Using the File Explorer app one can copy files from their Android device over to the My Cloud.

The WD My Cloud for Android app along with the WD Photos for Android app both include the option to backup photos and videos from the Android device to the My Cloud. The apps typically backup photos/video taken by the mobile device’s camera and which are stored in the default camera/video location on the mobile device.

I just needed to setup a port forward in the router to allow the android ftp app to see the my cloud. The transfer rates are much quicker compared to the my cloud app which uses the internet to transfer files.

I’ll be researching more into an android app that can actually access network shares similar to a pc. Not sure if there is one available. ESexplorer only sees the my cloud via ftp.

If anyone is using a file sharing app to transfer files locally to their my cloud. Let me know.

From where are you trying to transfer files? From the local network or from a remote network? Using the word “LAN” generally means one’s local area network.

I have no problems transferring files using the WD My Cloud for Android app on my local network when there is no internet access on that local network. Same goes for ES File Explorer. There is no need to enable FTP (which I have disabled anyway) when using ES File Explorer on my local network or when using the WD apps/software locally or remotely.

With ES File Explorer one may have to manually add the My Cloud on the Network page in the app. The following example shows how I have the My Cloud entry configured in ES File Explorer on my Android devices.

Remote access is a different story. For remote access typically one would either have to use the WD apps/software, web portal, or enable FTP and do port forwarding (of port 21) within their local network’s router/gateway. There are possibly unofficial methods of remote access but currently the previously mentioned ways are the official methods.

Thanks for info. I am trying to transfer files across my local network. Both devices are connected to the network.

Previously when i have used the my cloud app the transfer rates were really slow and when disabled the internet from the router the my cloud wasnt accessable. Which led me to believe the app uses the internet to transfer files.

When i scanned the network for shares using ESexplorer it wouldnt pick up the My Cloud, however my pc’s can see it. I don’t think i have tried to manually add it, as per your screen shot. So i’ll give that a go tonight.

That tells me that for some reason, you are not connected to the LAN on your android device.

Did you try setting up the entry manually in ES File Explorer using the IP Address of the My Cloud? See my screen capture above, it shows the entry setup with the IP Address of the My Cloud.

The WD mobile apps will transfer files both locally across the local network and remotely from the internet.

Seems to be working now. I disabled the internet from the router and could still access the mycloud through the app. I can even pick it up through the network scan in ESexplorer. Weird… i swear its never worked like that in the past couple of years ive had the my cloud.

Thanks for the info.