Sudden My Cloud Mirror access problems

Sometime in the past week or so, I’ve had trouble accessng My Cloud Mirror 4TB NAS, even though I’ve made no changes to my devices or their SW (incl. virus/firewall). Here’s what’s happening:

  • Device status is blank in WD Quick View (Used 0% - should be ~52%; Temp Unknown).
  • Unable to access NAS on tablet using My Cloud app. Shows devices but says it can’t connect. Unable to login.
  • Unable to access Dashboard via LAN on PC or tablet.
  • PC can still see and read/write files to NAS.
  • Lights on front of NAS are normal (blue).

I’ve recycled power on NAS and LAN router, as recommended in some posts, with no success.

I’ve never had a problem like this before so I’m stumped why it has happened suddenly.

Any help would be appreciated.


Did you try performing a system only restore?

Hi G_Rayn,

Yes, I did but there was no change. After reset, all lights end up blue but still no dashboard access (Unable to connect). PC can still access mapped drives, which is strange. Tablet can’t because I can’t login. It’s like server s/w has stopped running.

I just used WD Access to check properties and it shows FW version is 0.0.-1. Other properties look OK. Is it possible that the FW has been corrupted and, if so, is there some way to re-install it if the dashboard won’t work?

Maybe also check via your router what IP address your MCM is on and try accessing it via that IP address.

It may be that the IP address has changed, and so some of your links (which may use the old address) won’t work, but any that either use the new one (or DNS resolve a named link so will pick up the new address0 may still work, for example your mapped drives.

I have checked/done the following things since the problem arose:

  • Tried to connect from tablet via My Cloud app (sees MCM but can’t connect - says upgrade FW, but this is a std suggestion).
  • Cycled power on MCM (reboots with blue lights but no change).
  • Router (reset - no change).
  • Tried different browsers to access dashboard (Firefox, Chrome, IE - same error).
  • MCM IP address on router (hasn’t changed).
  • MCM connection to router (looked OK but tried another port - no change).
  • 4 second reset (no change).
  • Disconnected attached MC usb drive and repeated power cycle and 4 second reset (no change).

I guess 40 second reset will be next. Luckily, most of my MCM has been backed up on the separate MC usb drive so I won’t lose anything.


MCM won’t respond to shutdown command from Quick View or WD Access.