WD access app Stuck


Im not sure if there is a thread made for this but i am so frustrated due to not finding any answers online. The WD Access app for Windows 10 was in the middle of uploading files to my cloud and then announced that it lost connect, then it said after a minute later it was established again but was not upload. This keeps happening over and over again. I can sign into the dashboard and my cloud account, I have tried uninstalling and reinstalling the app, i tried doing a hard rest on my entire network including bouncing the router along with just trying a different port on my router and nothing seems to be helping.

Am I missing something? I am so frustrated with WD support when you call them and i don’t want to deal with them again if I can’t help it

Hi jrmikucki,

You can check and update the firmware version of My Cloud Mirror. Then map the Shares manually and check for the same issue.

Firmware is up to date. How do you do the mapping? I don’t have my cloud mirror it’s just my cloud 4tb