No access to WD My Cloud via dashboard or IP address

So I tried to access my NAS remotely today to be told the device could not connect. When I got home, I tried from the host machine and still found the NAS inaccesible. I tried to access via the IP address (a static address which according to the router has not changed) and it still won’t connect.

I can still access the files on the NAS via mapped drives or other means, but I cannot connect to any web services or the dashboard. So even if the thing needs its firmware updating, I can’t access the screen to do it.

Can I assume that WD have royally ballsed up the device once again? This is why I refused to upgrade the firmware for ages. When I finally relent, what a surprise, the whole thing falls over.

It really is unacceptable. Apologies if there is a solution, but I couldn’t find it.

I had trouble accessing one drive at home tonight.

I upgraded the MyCloud app. No joy.

So I used the ‘Manage devices’ tab and deleted the offending drive. The drive then immediately appeared as an ‘Available device’, so I selected that, entered my password, and bingo! Access resumed. Cloud access is disabled on this drive, but the app gives me local access.

This is on Android. I don’t use the app for local access, but I was testing access to my drives, since I couldn’t connect remotely to the drive which has cloud access enabled.

Thanks, but I think you’ve missed the main point.

I cannot access my NAS via any web service, be it from a PC or an Android device whether the device is removed and replace or not.

I cannot access my NAS from the PC that has the configurtion software installed.

I cannot access my NAS via the IP address e.g. http://192.168.x.x

When I try and access a remote service via an app or webpage, it will tell me to try upgarding the firmware. Given that I cannot get to the dashboard to upgrade the firmware, this is not very helpful.

Despite all of this, my PI, bluray players, android devies and PCs can all still access the content on the NAS via a mapped connection, so the drive is obivously working but I cannot get into the management of it or access via a web portal.

Unless I’ve missed something, I’m pretty sure I’ll be going back to ‘don’t update firmware’ after this.

1 Like

Really? No response from anyone on this? I have a NAS that I cannot configure!

Never had the problem, so no experience to give.

Lack of dashboard suggests the apache web server may have crashed.

SSH in and do a service status:

service apache2 status

Then, if it looks iffy, issue a restart

I managed to force a reboot via Winscp and I now have the dashboard back.

However, now i have the no internet connection 22004 error.

I am starting to think the my cloud is a honking pile of 5h1t3

1 Like

Hi, well i have the same problem after having tried resets many times and attempted to upgrade firmware. How did you do reboot via Wincp or did you find a solution?

One can reboot or perform a shutdown of the WD My Cloud via SSH by issuing one of the following commands while logged into the My Cloud via SSH.


Shutdown and power off:
/sbin/shutdown -h -P now

Shutdown only:
/sbin/shutdown -r now

Power off only:

There is further discussion on the use of these commands and using other programs to issue them at the following thread.

Hi, I see someone has answered but I’m afraid after the disk died and the replacement they eventually sent also being DoA, I ditched the crappy My Cloud.

They use WD Green disks in these and frankly, these are not up to the task of a NAS. That’s why they make the Red which is. I now have a WD Red disk inside a Synology DS115j NAS and the improvements are massive in every single way.

As far as I know the My Cloud single bay units use WD Red drives, or at least the couple that I’ve seen opened (including mine) do.

Not the cheaper lower capacity units e.g. My Cloud 3TB. Definitely Green as standard and insane business sense to put a non-NAS HDD in a commercial NAS product for the sake of a few quid.

Yes even the 3TB is a red drive. This review of the My Cloud has a picture of a red 3T drive in the My Cloud. This video (at the 2:21 mark) shows a red drive inside a 1T My Cloud.

It is possible other WD devices like the My Book Live have Green drives (see this review for an image).

Well given that WD told me specifically that these NAS drives were fitted with Greens as standard, I’ll take their word over the Internet’s.

I’m sure you’ll find some out there with Reds, but these are anomalies not the norm.

Personally, I’d rely on “the Internet’s” word over that of WD support; heard too many tales of WD support talking nonsense.

My 2TB MyCloud is a Red drive.

Out of curiosity, do you have any evidence to back up that the red drives are anomalies and not the norm in the single bay My Cloud drives? Something other than the word of some WD support person who may (in all likelihood) be wrong?

If you have a single bay My Cloud do a hdparm -i /dev/sda1 from SSH. Then Google search the Device Model result from the hdparm output.

Well, he was a senior support person who knew his shizzle to be fair. The one I had that died had a Green in, the one they sent that was DoA had a green in and if you look at Amazon reviews, you will see lots of people pointing this out.

What, may I ask, makes you think you’re right about Red drives being fitted as standard?

I’ve seen four My Cloud drives opened and all of them had Red drives. Others here report Red drives in their My Cloud’s as well.

MyCloud is based on Western Digital’s WD Red hard drives specifically designed for regular NAS use and features a new dual-core processor.

The My Cloud line comes with Western Digital’s Red drives, which are designed to be used in consumer network-attached storage (NAS) systems.

When I talked to WD support about the sleep problem. They said don’t worry the disk
is designed to run 24/7.


Which Amazon reviews? Looking at this WD My Cloud Amazon reviews link there are approximately 2,748 reviews for all models of WD My Cloud drives (single bay). Of those reviews, doing a search for the word “green” turns up 11 reviews, of which it appears just one reviewer stated; “I went with the cheaper model which (I think) has green drive vs red”.

As to the difference between the Red and Green drives there is the following article that attempts to explain the difference.

Look, you believe what you want to believe.

WD Red drives are great for NASs. Their My Cloud boxes - and especially the software they use - are not.

I think I ended up spending an extra £20 or so to get the WD 3TB Red drive and a Synology Diskstation. The hardware is better and the software is immeasurably better. I’m sorry, but that’s the simple truth.

You obviously like your My Cloud and more power to you for that. If you’ve got one with a Red drive in then even better luck for you. However, you’re still having to use their crappy firmware and software interface.

I will say that the WD forum is a bit more proactive and helpful than the Synology one though.