Sonos error: Unable to play “song name” the connection to my cloud home was lost

I continue to get this error when playing music stored on my My Cloud Home through Sonos.
I have reserved an IP address through my Actiontec router and I have plugged it directly to my router instead of my switch. None of these solved the issue.
It’ll play for a while and then just decide to quit.
Has anyone actually got this working well?
The last post on this topic seems to be back in 2019.

Hi @rsiebert,

Please refer to the below link to check supported music format:
https://support-en.wd.com/app/answers/detail/a_id/15790

Please refer to the below link to know 3rd Party App: Sonos Message "‘song name’ is no longer available on My Cloud Home:
https://support-en.wd.com/app/answers/detail/a_id/14630

Thanks for the response. I have been using m4a format which appears to be supported.
Here is a list of things i’ve done to try to get this to work

  • static IP for both Sonos Port and Wd My Cloud
  • turned off firewall
  • enable smb v1.0
  • enable network discovery
  • enabled tcp over netbios
  • ininstalled and reinstalled My Cloud
  • tried different ports on my router

sonos port is hard wired so it shouldn’t be a wifi problem
I’ll try sending a diagnostics report to Sonos to see if they can spot anything
I am not convinced that my private and public domains are set up properly. I loaded my music on my private drive (z:/ under My PC) but I can see all the music files when i look at the my cloud folder under Networks in File Manager

Hi,

I appreciate that you have performed the troubleshooting steps.

Please contact the WD Technical Support team for best assistance and troubleshooting:
https://support-en.wd.com/app/ask