Something went wrong. check that you have an active internet connection

unable to login to mycloud home device

via windows laptop and macbook
tried 4 different browsers
chrome, edge, opera and firefox

I am still able to access it via the iphone app.

Error message below
something went wrong. check that you have an active internet connection

try power cycling the unit and see if you can connect

can you explain power cycling?

unplug the power cable, wait 10 seconds and plug it back in

You may want to see the correct subforum for your device. The My Cloud Home is a completely different device than the My Cloud line of devices and further is not supposed by the OS5 firmware.

My Cloud Home
https://community.wd.com/c/home-cloud-storage/my-cloud-home/229

The usual troubleshooting steps should be tried (if they haven’t been).
If remote access can be disabled/turned off in the device settings, disable/turn off the remote access option. Wait a few minutes, then re-enable the option and see if the issue persists.
Turn off the device, wait a few minutes, then power the device back on.
Disable any browser add-ons and see if the issue persists.
Disable third party security/firewall programs on the computer and see if the issue persists.
If using any form of ad blocking programs or systems (Pi-Hole, etc.), disable them and see if the issue persists.

Tried all the above - no luck

@dalglish07 Check your email inbox or junk folder for a “Blocked Access” email and then click the link to unblock. If you do not get this email, contact support with your external IP address. You can find it from here, https://whatismyipaddress.com/

image

had that email. unblocked. but issue still persists

@dalglish07 I’ve sent you a private message

Can you provide an update? @SBrown

I have the same issue, do you have a way to fix it?

I am having the same issue. Do you have a fix for it?

@lisanevets @Shyngox85x @dalglish07 have you opened cases with support and provided the system logs from your My Cloud device? If not, please do so.