Mycloud offline

I am trying to access the My cloud homepage but when i sign in i get the message that my device is offline even though i can access it via my Mac and also the dashboard. Firmware is up to date.
The devices icon is greyed out and if i click on it i just get the Device Offline notification.
Nothing sems to be working on the Mycloud home web page for my device.

Some help will be gratefully received

@ade123 Have you looked at the Learning Center for more information and the User Manual for the My Cloud Home?

Yes i have searched the learning centre an also read the manual but cannot find anything relating to the issue.
I can’t understand why everything is working via my computer and the dashboard but I’m unable to access the drive via the MyCloud web page.When i log in it constantly says it is Offline and greyed out. has been having problems lately. You can try a different browser but it still may not be working.

Many thanks for the advice. I have tried Firefox and still the same so will have to wait until
the issue is fixed.
Hopefully in the near future

Nearly two weeks now with this issue and still get informed the drive is offline.
Looks as though tech support don’t give a ■■■■ about fixing things

I just tried it on my Desktop using IE and it worked. What browser are you using?

Is this the WD device you own? WDMyCloudImage

You are still posting in the My Cloud Home sub-forum. If you have a My Cloud Home then you should look at the link I provided in a prior post for the User Manual.

Yes apologies for posting in the mycloud home forum instead of the Mycloud.
I have tried google chrome,safari,Firefox and still the issue.
I use a Mac so no IE
I noticed a few others with the same issue in the Mycloud forum and I’m not holding out much hope of a fix in the too near future.