Smartware Update Stops and Won't Install

I have just received a notification that there was an update to my Smartware Pro software. I clicked the message to accept the update and a window for WD Software Download appeared. It has a progress bar indicating that it is processing WD_SmartWareInstaller_2.4.14.13.zip but there has been no progress in the window. Task manager also shows zero CPU usage. What do I need to do to get it to run? I am running Windows 10

2 Likes

Exactly the same problem here, running Win 7 Home Premium. Updating from 2.4.12.

1 Like

You can download it directly from the support site here: http://support.wdc.com/downloads.aspx?DL

I’m checking into this now.

I just downloaded and installed the SmartWare update on my desktop, Windows 10, from this location below (My Cloud). Click, tap or activate downloads tab.
http://support.wdc.com/product.aspx?ID=904&lang=en
I saved it in my downloads then unzipped it and installed without any problems.

Click, tap or activate image to enlarge it.

cat0w
USA

1 Like

What has happened now is weird. I went to the link given by EDColeman3 and when I clicked on the link for my unit, nothing happened at all. When I went to the link given by cat0w the available download was for 2.4.13, not 2.4.14. I have just opened Smartwar again and it says I am on 2.4.12 but when I use the check for updates button within Smartware it says there are no updates available!!

I just retried the link from EDColeman3 and that took me to a different page this time where I found a link for Smartware 2.4.13 but this is not for Passport Ultra. I guess there must have been a hiccup in their update system somewhere and my software is up to date with 2.4.12

Thanks, guys, for all your help

It may be that you have to update to 13 from 12 and then to 14 from 13.

cat0w
USA

To clarify - I was having the exact same problem with the update to 2.4.14 (from my current 2.4.12) and on the release notes / software update page it did NOT indicate that the update was for My Passport Ultra (it did indicate it was for My Passport Ultra Metal)

So as a Passport Ultra user, do you think I should just ignore the update notice?

Many thanks

I have just updated successfully from 2.4.12 to 2.4.13 (I found that the latter update had downloaded on to my PC) but the download for 2.4.14 still stalls and won’t download. I too am using My Passport Ultra.

I successfully downloaded 2.4.14.13 from this link: http://supportdownloads.wdc.com/downloads.aspx?DL

I noted that the Release date was three days from now.

The download succeeded and I was able to open the installer and it ran to completion.

After reboot a window popped up and said that my recycle bin on that drive - the WD MyBook - was corrupted, and did I want to empty it. I chose no because I wanted to see if the update worked, which it did. The settings tab showed 2.4.14 (previous was 2.4.12).

At last! I am now updated to 2.4.14 from the link above! Thanks again, everyone, for all your help. It has been much appreciated :slightly_smiling:

Got the same problem on Windows 7 Pro, even closed the splash window and tried again with a manual update and failed :frowning:

How to? Please tell me

Thank you … worked for me :heart_eyes:

Here is the link to the file:
http://download.wdc.com/smartware/WD_SmartWareInstaller_2.4.14.13.zip

I’ve had the same problem installing WD_SmartWareInstaller_2.4.14.13, but have NOT had the success others have mentioned here. The installer shows no progress bar movement, then tells me the software is installed. Yet, it shows up no where. Not even in the program list under control panel. Nor does it come up with a Windows search. I am running Windows 7 Professional 32-bit.